beagle board bricked

Hi,

I got a new RevC3 beagle board, and it was working great for a while
until I started chaining usb hubs on the EHCI port. This caused the
kernel to crash and when I rebooted, it no longer booted uboot.

The only output I get is "40V" on the serial port. It prints then at
power up or when pressing the reset button.

I have a RevB beagle board also and an SD card to rescue. This board
boots fine off the sd card, just to be sure, I erased nand. Then the
revB board only printed "40T" with no sd card, and nothing else at
power up. I was still able to boot off the sd card, flash the nand,
and put uboot back in nand then boot linux with no problems.

Using the same sd card, and all combinations of user and reset key,
the revC board is still stuck. Has anyone seen this? Does anyone
know what "40V" means? How come the revB board prints "40T" when
nand is erased.. what does "40T" mean?

Thanks,
Sean

Hi Sean, have you tried this yet? http://elinux.org/BeagleBoardRecovery

- Dan

Hi,

I tried everything on that page, it doesn't explain the problem I'm
seeing or a solution.

Sean

I just looked in the SRMs for Rev C2 and Rev B5. 40V (C2) and 40T
(B5) are documented in section 13.2.

It means that the processor is booting, and then it says to make sure
your SD card is inserted correctly and formatted correctly, which you
have done.

I have not seen the issue you describe.

-Preston

Hi,

Should I request an RMA for this? I have not modified the board and I
don't think I have done anything which should have caused this issue.

I need to order parts from digikey anyway tomorrow, so I'm wondering,
if I get another beagle will I eventually get refunded for the first
one? I would rather get a replacement sooner rather than later, I
need the beagle right away.

Thanks,
Sean

DigiKey does not handle the RMAs. They go direct to www.BeagleBoard.org/RMA. If you follow the instructions found at http://code.google.com/p/beagleboard/wiki/BeagleboardRevCValidation exactly as described, no shortcuts like an already formated card, it will unbrick the board everytime. If you can’t get that to work, you can request an RMA it it will take them 20 seconds to unbrick the board.

Gerald

I will request an RMA. I hope they can fix it in 20 seconds. My sd
card unbricks my revB just fine, so I'm not sure why it isn't working
on the revC.

Sean