Beagle board kernel freeze

Hi,

on beagle board rev C5, we are getting kernel freeze. all the 3.X
versions are giving same problem. i tried bootargs instead of "ttyS2"
with "ttyO2" also. But no use. Please help us to solve. we are facing
problem from long time. below i'm pasting the console log.

i found solution for the freeze problem by browsing. i'm using
CodeSourcery 2011.03-41 compiler. the below link solved the problem.

http://blog.galemin.com/2011/05/linux-kernel-2-6-39-codesourcery-2011-03-41-alignment-exception/

But now i got kernel panic error.

/******************************************************/

   2.214630] VFP support v0.3: implementor 41 architecture 3 part 30
variant c rev 1
[ 2.222839] ThumbEE CPU extension supported.
[ 2.285400] clock: disabling unused clocks to save power
[ 2.297454] regulator_init_complete: VDVI: incomplete constraints,
leaving on
[ 2.305328] omap_device: omap_i2c.1: new worst case activate
latency 0: 244140
[ 2.313629] regulator_init_complete: VDAC: incomplete constraints,
leaving on
[ 2.322540] twl_rtc twl_rtc: setting system clock to 2000-01-01
00:07:32 UTC (946685252)
[ 2.336151] Root-NFS: no NFS server address
[ 2.340759] VFS: Unable to mount root fs via NFS, trying floppy.
[ 2.350891] VFS: Cannot open root device "mmcblk0p2" or unknown-
block(2,0)
[ 2.358276] Please append a correct "root=" boot option; here are
the available partitions:
[ 2.367279] 1f00 512 mtdblock0 (driver?)
[ 2.372711] 1f01 1920 mtdblock1 (driver?)
[ 2.378143] 1f02 128 mtdblock2 (driver?)
[ 2.383575] 1f03 4096 mtdblock3 (driver?)
[ 2.388946] 1f04 517632 mtdblock4 (driver?)
[ 2.394378] Kernel panic - not syncing: VFS: Unable to mount root
fs on unknown-block(2,0)

/
******************************************************************************************************/

Please help me to solve the issue.

Thanks You
eswar

Kernel could not find the file system. Check Bootargs

Hi Nikhil,

Thanks for reply. here i'm listing the bootargs that we used

setenv bootargs console=ttyO2,115200n8 root=/dev/mmcblk0p2
rootfstype=ext2 rw rootwait

still kernel freezes at the end

/
*********************************************************************************************/

[ 2.946258] mmc0: new high speed SDHC card at address 0007
[ 2.956054] mmcblk0: mmc0:0007 SD04G 3.70 GiB
[ 2.970214] mmcblk0: p1 p2
[ 3.066864] EXT2-fs (mmcblk0p2): warning: mounting unchecked fs,
running e2fsck is recommended
[ 3.405700] VFS: Mounted root (ext2 filesystem) on device 179:2.
[ 3.413269] Freeing init memory: 308K
mount: mounting none on /tmp failed: No such file or directory
/
*************************************************************************************************/

after the above message kernel stopped. can you please tell me what i
can do to solve bug.

i have angstrom pre-built uImage downloaded from angstrom website.
with the following command i'm able to boot file system

setenv bootargs console=ttyS2,115200n8 root=/dev/mmcblk0p2
rootfstype=ext2 rw rootwait

i used ttyS2 insted of ttyO2 because the prebuilt image is old kernel.
But i used same file system.

Thank you
Eswar

You can check the /etc/inittab of your file system.
If it is ttyS2, then change it in to ttyO2 and check and create /tmp directory in your fs.

Dear Nikhil,
Thanks for the help. Now, after i changed the /etc/inittab file
for ttyO2 i'm able to boot into root.
Thank youeswar