Beagle Board Not booting and LEDs also not glowing

Hi Team

Good day for all,

I’ve bought a Beagle Board Revision B7. I’ve installed Angstrom Linux and tested the board. Every thing working fine. But after that I’m trying to install QNX, for that i’ve followed procedure.


These commands will transfer the IPL from the SD card and overwrite u-boot

  1. mw.b 80000000 ff 40000

  2. fatload mmc 0 80000000 nand-ipl-omap3530beagle.bin

  3. nand erase 0 40000

  4. nandecc hw

  5. nand write.i 80000000 0 40000

These commands will transfer the .ifs to nand in order to be loaded by the QNX IPL

  1. mw.b 80000000 ff 600000

  2. fatload mmc 0 80000000 beagle.ifs

  3. nand erase 80000 600000

  4. nandecc hw

  5. nand write.i 80000000 80000 600000

But suddenly my board stopped working. I couldn’t able to see the boot messages on serial port terminal. USR0, USR1 and PMU LEDs also not blinking. I don’t whether it is software issue or hardware issue. Please give me reply with solutions.

OK. How about this. Sounds like you trashed your NAND. Holding the USER BUTTON down while powering up will force it to boot from the SD card. To restore the NAND to the factory state follow the instructions here:

The code you overwrote the NAND with is bad. It does not work. It will not boot the board. As to what is wrong with your code, I cannot say.


Actually by mistake i connected my RS232 cable in Reverse Order. So
i'm just thinking because of that will there be a issue eith board or
not. What you say regarding this??

There may indeed be. Sometimes it can be an issue and sometimes not. Watching the LEDS or connecting a display may help give you an idea if it is booting.


Hi Gerald. I tried the link which you have given…
Still problem not solved. Is there any other way to bring the board

If it can’t run this code, then you have an issue somewhere on the board. Best bet may be to request an RMA and see what has happened to the board.


Hi Gerald,

Still my beagle board not working. I couldn't able to resolve the
problem. I've tried so many ways still in minicom nothing displaying.
I've raised RMA request, they are asking me to send board. But I'm
from india. So i'm thinking that whether i need to send board or

Suggest some thing.

Return the board or pay for it. That is the process. If you have something else that you are doing wrong, then the new board will work the same.