Beagle Board Recovery Problem

Hi Eveybody

I have BB Rev C4. A few months ago I formatted the 4gb MMC card with
two part (Fat and EXT2) and copied uImage to FAT partition and tar ed
Angstrom demo image to EXT2 partition. It was working properly with
usb mouse keyboard or any thing. To run the OS plugging the power
was enough. After that I erased nand with these two commands (nand
unlock nand erase). (What is the reason to make this I don't know
really :slight_smile: ) Any more my BB could not boot again and In minicom only
weird chars appears (some times "40" or "@" appears)

So to brick my BB I found three recovery choices. MMC recovery , UART
recovery and USB recovery in the eLinux.org page

1-When I try the MMC recovery no changes happen on the board only pwr
LED is on and hangs . In minicom only weird chars appears in this
method

2- For UART recovery it works but only New User Page appears onthe LCD
screed and Mouse, Keyborad or any thing on USB port does not work. On
my Linux host machine, in minicom Beagle Board login promt appears so
I can login as a root but on the LCD screen, that I plugged to DVI
port of BB, any changes occurs New user page hangs. In this recovery
method, the problem is that; when the power off or reset the board It
does not boot again so I have to follow the UART recovery script again
and again for all restarts. If this method recovers BB, Why do I have
to make it again for all resets?

3- For USB recovery with the guide of "http://
nishanthmenon.blogspot.com/2009/01/beagleboard-recovery-take-2.html"
In this method ;after downloaded the files to BB it hangs at this
step;

I attempted to boot BB one more time, but fot this time I plugged the
mouse before power on the board and the mouse works now. (with UART
recovery ) But again After I reset the board I must apply again
recovery prodecure .
I think there is no one who interested in this topic :frowning:

I am interested because I have a bricked Gumstix board and I'm in a very similar position to you. I have today off work so I think I'll play with the recovery procedure a bit. This will be my 3rd or so try.

Sometimes it all comes down to try, try, try again.

Bob Cochran

Thanks for your interest :slight_smile:
I don't know how many times I tried. My problem is that, after I
recovered BB, when power is off, It can not save the modules to nand
they are erased so the next time I recover again with Uart procedure

Regards Ahmet

If you will register, your posts will got through without moderation. Otherwise you next post may not go through until next week. No reason to keep sending as many posts as you are asking the same question. Start a new thread and do not keep tacking your question on to existing threads, If you insist in doing it, trust me. No one will answer you.

Gerald