Beagle Board Screen Resolution Angstrom Linux

Hello,

    I was able to install and run Angstrom Linux on my Beagleboard xM.
But when I connected it to a LCD Monitor via HDMI to DVI-D cable, the
screen resolution that was coming is 640x480. With that screen
resolution it was very difficult to work as most of the windows were
exceeding the screen height.

Do we need to install some driver for graphics? or is this resolution
is the maximum that it supports.

Thanking in advance

Jasmeet Singh
IIIT Hyderabad

On Apr 30, Jasmeet Singh wrote to the beagleboard group:

I was able to install and run Angstrom Linux on
my Beagleboard xM.
But when I connected it to a LCD Monitor via HDMI
to DVI-D cable, the screen resolution that was
coming is 640x480.

Hi,
I currently have the same problem. Did you solve this?
I have tried changing the boot commands to a higher
resolution, as described in [1], but did not manage to
cause any change. But I will try again, using my real
kernel parameters from "cat /proc/cmdline".

[1] http://guillaume.segu.in/blog/hackens/337/getting-started-with-your-brand-new-beagleboard-xm/

Best regards,
Robert

Hello,

I couldn’t solve this issue.

I used another BeagleBoard xM Rev C which had its pre-installed Angstrom Linux and the resolution problem was solved. So I didn’t try to look more into it.

Regards
Jasmeet Singh

Can you provide the complete serial log and the contents of your uenv.txt?

Hi

I am using these parameters in uenv.txt and its working fine with my
Angstrom image
Have tested it on my Benq and LG monitor.

mpurate=1000
dvimode=1024x768MR-16@60
vram=12MB
bootargs=console=ttyO2,115200n8 console=tty0 root=/dev/mmcblk0p2
rootwait ro
vram=${vram}
omapfb.mode=dvi:${dvimode} fixrtc buddy=${buddy}
mpurate=${mpurate}

if it does not work with the above parameters then may be try with a
different Angstrom image

Regards,

Anuj

Can you provide the complete serial log and the contents of your uenv.txt?

Hello Jason,

that was a really good request. It helped me fix the problem!
Up to now, I did not know about uEnv.txt. I was using only a boot.scr
file, as described in [1] below.
Googling for uEnv.txt lead me to the thread "omap3_beagle: enable the
use of a plain text file named uEnv.txt instead of boot.scr" [2].

So I replaced my boot.scr file by an uEnv.txt just containing
"dvimode=1024x768-16@60" and that did the job!

(For the record, I am using a current Narcissus image with the
settings "simple", "Gnome", "Bootloader Files".)

Thank you very much!

--Robert

[2] https://groups.google.com/forum/#!topic/beagleboard/u2A51YpBJcs/discussion