Beagle bone black giving C character

My beagle bone black was working fine and after some time its now giving only character C on uart port.I tried to flash a new image still it gives the same C character.Can anyone tell me what should i do to bring it back?

You need to either flash the eMMC or put a bootable SD card into the SD card connector.


This means that the BBB is trying to boot from the serial port.

This usually means that the BBB can not see a valid image in the eMMC or on the uSD card, if present.
It is searching desperately for something to boot from. So load a new image, like Gerald says.

Less likely, it might also mean that you hung some some I/O loads on the pins that control boot
configuration and order, and you are overriding the on-board boot instructions. Disconnect all your external
I/O from the LCD pins and try again. If this works, go read the System Reference Manual.

— Graham

As you told,I tried to flash the latest debian image.But still i got some error.I am attaching the snapshot of the error with this mail.I am using A6 version of Beagle Bone Black.
Please find the attached mail.

Make sure there is nothing plugged into the expansion headers. If you can’t flash it, request an RMA and we will flash it for you.