Beagle Bone Black will not boot or flash

Hi all,

I have a Beagle Bone Black RevC that I got in late 2016. I flashed it with Ubunutu 14.04 and installed ROS and had a blast with it. Recently I decided that I would flash the board with a version of Machinekit to control my CNC machine in real time. Before I did this I made sure my BBB was alive by SSHing in and copy all the ROS stuff I had on it. Then I shutdown, and unplugged. Next I flashed a 4GB uSD card with the latest turn key install of Machinekit, put the SD card in the BBB and held S2 while I plugged in a 5V 2amp power supply. After multiple hours the four user LEDs did not go solid. I unplugged it, downloaded Angstrom and tried again. Same issue. I tried multiple times either not pressing S2 and pressing S2 and with multiple debian distributions with no success. I then installed “BBBlfs” ( and tried to install Machinekit over USB. I ran the script and the user leds flashed showing CPU usage and emmc usage, the script also did not prompt me with any errors. I thought that I was in good shape, but now when I plug the board in it just flashes the USER0 and USER2 LEDs for a little bit and then just goes dead and USER0 blinks twice every couple of seconds. I tried flashing Angstrom over USB with similar results. After all this mess I tried the SD card method again, but I still only get two flashes of the heartbeat with no emmc or CPU activity. Do you guys have any suggestions? I obviously am unable SSH into the BBB. I have a miniHDMI cable coming in the mail, so maybe that will help me out but I doubt it. Any help is appreciated. I also have tried pinging with no success. My macbook will also not even recognize the BBB as a device.

Thanks so much,