Beagle bone+debian+wifi

I have a Belkin N150 micro usb adapter that works with debian wheezy on my raspberry pi just fine(using all the gui stuff) but I seem to be missing something when it comes to getting it to work with my bb running debian wheezy minimal. I did the apt-get update/upgrade first then I figured out I needed locales installed before I could get ssh server working right.

I’ve install the realtek firmware like I did on the pi, and it now shows up with lsusb, also installed wicd curses, nano, mc, and some other network related stuff.
I’m trying to do this all command line wired via ssh mostly as a learning experience to get away from all the fancy gui stuff. I tried editing the network config files but I must not be doing
something right.
I’d like to have it look for the wireless first before the wired network, but for now i’d just like to get wifi working.

So far Googling hasn’t found anything that fits my problem. I’m probably not using the right terminology for it to work right

So, how are you configuring the network? Are you running wicd-curses and using that curses interface to connect to your wifi?

wicd-curses is what I have been using
then I tried ifconfig wlan0 down then ifconfig wlan0 up, now the blue is on.
but when I try to setup wpa with wicd-curses lots of errors scroll past then quits.

If you could post the errors then that might help, it sounds like it may be failing and then printing a back trace. In which case it would be a debian wicd-curses packaging problem.

I would also suggest to disable any wireless security on you router first, if you can.

Instead of ifconfig I use iwconfig, which is apparently more useful for wireless network setup.

Look up the syntax for iwconfig commands, from memory you have to set the name of the wireless network using the essid option, something like:

iwconfig wlan0 essid “my wireless”

Later, when you want to enable any key, try the ‘key’ option

iwconfig wlan0 key XXXXX

Then check the status of the connection with iwconfig, the output should show an IP number for the interface. (Requires use of DHCP, which I think should be the case by default.)

(I managed to get this working using ubuntu on the beaglebone, also for a realtek based usb wlan adapter)


one problem I just solved is that I have to type “sudo wicd-curses” now wicd works with out
The new problem is when wpa is turned off at the router the bb now sees the ap but is not picking an ip address from the router, this is after I reset the router.

I’m still at a loss as to how to get this work, I started over again with a clean install now I’m stuck at my wifi no longer being recognized. Is there a how to somewhere on how to get wifi working on debian wheezy on the beagle bone? Some desperately needed howto’s is what I really need after loosing another day this problem.

Hello Dan,

we are playing with BeagleBones in our free time with a friend of mine. We had this issue some time ago and made some blog posts about it. We started with Angstrom but later on dropped it and moved to Debian.

Debian + wifi creating an access point:
Debian + wifi auto connect to configured wireless network

Angstrom + wifi + connman:


2013/2/14 Dan Hockey <>