[Beagle Bone] Sending commands through UART?

What are the linux shell commands to send commands to for example a
device hooked up to the UART TX on the beagle bone?

I have changed the pin/mux to "transmit" mode so all i need is the
couple of lines of code for sending commands through the perfferably
the terminal.

I tried out this tutorial:

But it didn't say specifically what the terminal commands were it was
only in python and the python script wasen't exactly included with
this tutorial. I've looked at general Linux Kernel and Angstrom
specific commands for UART but little success... i need some direction
thanks everyone!

When I was testing the connections for the compass and gps, I used minicom. You'll want to specify the -o option so it doesn't try to initialize a modem. So, for uart1 running at 57600bps:

minicom -o -b 57600 -D /dev/ttyO1


It let me open up minicom and showed me a screen that something like
the following....

Welcome to minicom 2.5

Compiled on May 2 2011, 10:05:24.
Port /dev/ttyUSB0

Press CTRL-A Z for help on special keys

How do I type commands in here? All i see is the Help scren by
pressing Ctrl-a then pressing Z

If the serial port is working, anything you type will go straight to your device, and anything the device is sending will be printed to the terminal.


I'm a nub at terminal apps, but i found on the internetz an
alternative called CuteCom it worked perfect! Thanks for the help
either way buddy :smiley:

My suggestion is to use gtkterm, no messing about with command line.
I have been using it for at least 12 years.

You fire it up configure the port to /dev/ttyUSB0 etc. and you are done.

Great! I've successfully been able to draw pixels on the screen! So
now if i wanted to send commands through UART with say something like
Java, How would I go about doing that? Does java natively support uart
stuff? Will I require any libraries?

you will need the rxtx library for talking to the com port.
It is opensource and compatible with sun.comm from sun(oracle)( which
it seems it's not being supported anymore...)
if you have debian or ubuntu install it from aptitude

sudo apt-get update

if you havent installed java do
sudo apt-get install openjdk-6-jre openjdk-6-jdk

for the library do
sudo apt-get install librxtx-java

and test it with the examples of http://rxtx.qbang.org/wiki/index.php/Examples
if you have an error like: lib not found
do this

sudo cp /usr/lib/jni/librxtxSerial-2.2pre1.so /usr/lib/jvm/java-6-
sudo mv /usr/lib/jvm/java-6-openjdk/jre/lib/arm/
librxtxSerial-2.2pre1.so /usr/lib/jvm/java-6-openjdk/jre/lib/arm/

sudo cp /usr/share/java/RXTXcomm-2.2pre2.jar /usr/lib/jvm/java-6-
sudo mv /usr/lib/jvm/java-6-openjdk/jre/lib/ext/RXTXcomm-2.2pre2.jar /

or whatever the version of rxtx look it up in /usr/share/java/ and /


Hi Vincent!

I’m trying to use this library and I got configure it in a virtual machine with Debian installed. I’m using Eclipse IDE and created a java project. I have also included the RXTXcomm jar as a library in the build path. I tried to run an example to obtain a list of comm serial ports available, but when I run the program I don’t have any error, just a warning:

Java HotSpot™ Client VM warning: You have loaded library /usr/lib/jvm/java-7-oracle/jre/lib/i386/librxtxSerial.so which might have disabled stack guard. The VM will try to fix the stack guard now.
It’s highly recommended that you fix the library with 'execstack -c ', or link it with ‘-z noexecstack’.
Stable Library