Beagle mmc Boot problem

hi

i have a Beagle Board Ver C4
i have copied the files MLO , u-boot.bin and uImage on the FAT32
partition
and rootfs in ext3 partion

but when i power on the beagle it always goes into read nand mode
i want it to boot from mmc card and it also does not give any chance
to hit a key to stop autoboot.

in order to boot from mmc i have to first remove my mmc card and
restart the
beagle board and then it asks to stop the autoboot by hitting a key
after i hit a key then i insert a mmc card and type boot to boot from
mmc

it is working this way but on restart this is not working..

i tried to sett to boot to mmc by default by

setenv bootargs 'console=ttyS2,115200n8 console=tty0 root=/dev/
mmcblk0p2 rw rootfstype=ext3 rootwait
omapfb.video_mode=1024x768MR-16@60'

and

setenv bootcmd 'mmc init; fatload mmc 0 0x80300000 uImage; bootm
0x80300000'

and i do saveenv to save the settings in nand which shows ok
but after i restart and mmc is inserted then it does not boot from mmc
it boots from nand which i dont want

I have a Ver B7 Beagle Board on which i have followed the same
procedure
and it is working ok..

try FAT16 type for the partition. Maybe it can because I heard same problem and solved with this change but I am not sure that this is a correct solution :slight_smile:

2010/12/24 An <anuj.tanksali@gmail.com>

Do 'nand erase 260000 20000' to get the default environment back that works. Alternatively, a 'nand erase' will also wipe and outdated bootloaders from NAND.