Beagle xm linux kernel build

After many days of building kernels, I cannot seem to get any to boot
on my Beagle XM. They all boot fine on my older Beagle C4, but I
can't get a single one to boot on the XM. I've been using
openembedded's recipes to build them by hand using x-compile
(codesourcery) on Ubuntu host. I've tried everything from 2.6.31 to
2.6.39 and no luck. All the patches seem to be applying fine, and
almost every single kernel boots find on my old C4.

I'm using a July 2011 version of uboot and x-loader. I get
"uncompressing done...booting the kernel" and all my led's just stay
on. Is there something simple I'm missing here?? Do I have to pass
some funky cflags because of the XM??

please post your bootargs's..


Generally, it's: "console=ttyS2,115200n8 console=tty0 root=/dev/
mmcblk0p2 rw rootfstype=ext3 rootwait" (although for kernels >=
2.6.36, it's console=ttyO2 and for older ones, it's console=ttyS2)

Since the XM has no NAND, the bootargs pretty much default all the
time and I can boot a prebuilt narcissus kernel using the same default
args. I don't think this is the "can't see the boot messages because
I have the wrong tty" situation...I can tell when she's locked. Plus,
I've got the HDMI plugged in as well. If there's any question, I even
give it 10 minutes and check all ttys and video to see if it came dice!

This thing is locking hard and I've just about hit my limit to figure
out why? I can even build a kernel using openembedded and it boots
fine. But I can't get my hand built to work on the XM, although they
all work fine on the C4 board. I was sure it was the alignment flag
issue with codesourcery 03-2011 (
note_id=10150197506659362) but I've turned it off with -mno-unaligned-
access and still no luck. I really need to hand build em' since I
have to apply Xenomai to the kernel and that's no small feat for some
of these omap patches! I've been using a method I've developed using's manual OE build stuff and on the C4 it's been flawless.
I've built several kernels with Xenomai support that work great on the

I've now started using the TI tree (
integration/kernel-omap3.git) but I can't seem to get a kernel to
compile all the way yet. And, since tmlind's directory is now gone
from after the security breach, I guess I need to find a
new mirror for a vanilla linux-omap-2.6 kernel tree....

I did try using the gcc arm toolchain from OE in my linux-omap2.6 tree
that I've been using and it's uImage locks too. I guess I really need
to blow my tree and get another vanilla going, but we'll see how the
TI one does I guess. I've tried the vanilla omap tree patched 2.31
through 2.39 with no luck. Any ideas off the top of your head?

I'm having a similar problem on my XM with the current demo build from
the Angstrom site (
beagleboard/). The only differnece I see is that the heartbeat LED on
my board continues to blink regularly after it gets to "uncompressing
done...booting the kernel".

Wondering if you might try their demo image to see if it works on your
board and report back (that way I'll know if it is just me or not).



The demo image boots on my XM...the boot messages end up on the HDMI
regardless of the console setting. It doesn't seem to finish all the
way gets pretty far but I didn't see getty start up. You
could leave it run for 30 minutes and see, but I don't think it'll
finish. If you want a quick image, use Narcissus (http:// or OpenEmbedded and you can get
an Angstrom that boots fine on the XM. I've booted several from each
of these and they work fine as long as the driver compliment is close
to correct. I'd say that demo image is close, but not quite correct
on the XM.

Unfortunately, I don't even get this far with my hand built
kernels...all the LED's lock solid right after the "booting the
kernel" message with no more activity. I've now tried building an
image using TI's tree and same result. I'm starting to wonder if my
tincantools protoboard is causing this? I think I'll remove it and
see if it'll boot....

OK thanks I'll give that a go.