Beagleblone Black LC_CTYPE LC_MESSAGES LC_ALL

Hi, all:

I’m playing with my Beaglebone Black, having ubuntu-13.04-console-armhf-2013-07-22.tar.xz installed. Whenever upgrading/installing some packages, I noticed

locale: Cannot set LC_CTYPE to default locale: No such file or directory locale: Cannot set LC_MESSAGES to default locale: No such file or directory locale: Cannot set LC_ALL to default locale: No such file or directory

Just wondering what are these 3 parameters for, and what are the influences without setting these 3 parameters?

Best Regards
Pei

You might be missing an /etc/locale.conf or /etc/defaults/locale file. GNU software has a mechanism to query what your current locale is to determine how you prefer to have currency, dates, etc. formatted when they are displayed.

http://www.gnu.org/savannah-checkouts/gnu/libc/manual/html_node/Locale-Categories.html

You can try apt-get’ing the glibc-locale package on the BBB. Also, make sure that the locale set up locally is also available on the BBB. If you’re ssh’ing into the BBB from a Linux machine, your locale on the Linux machine might not match a locale available on the BBB. If you see LC_CTYPE, LC_MESSAGES, and LC_ALL like you are, that is a likely possibility.

Andrew

Hi, all:

I'm playing with my Beaglebone Black, having
ubuntu-13.04-console-armhf-2013-07-22.tar.xz installed. Whenever
upgrading/installing some packages, I noticed

locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory

Just run:
dpkg-reconfigure locales

Then logout/login.. if it still fails, do:

export LANGUAGE=en_US.UTF-8
export LANG=en_US.UTF-8
export LC_ALL=en_US.UTF-8
locale-gen en_US.UTF-8
dpkg-reconfigure locales

Just wondering what are these 3 parameters for, and what are the influences
without setting these 3 parameters?

Mostly just annoying error messages..

Regards,