[beagleboard] [ 5.686767] JBD2: no valid journal superblock found error in BeagleBoard-XM

Hi to all

i have BeagleBoard-Xm Rev C runnung ubuntu 11.01 i have Host PC running
Ubuntu 12.04.1 when i serially connect it to Host PC it starts booting but
sudden stop and hang and then no process happen ahead. Please help me out.
when i use Xp host it start booting but stop and hangs on login. please help
me.

Ignore my other message, as i see you've emailed a few times. :wink:

How are you poweing the xM? 5volt DC or via OTG?

here is the process when i connect BB-XM to Ubuntu Host

U-Boot SPL 2012.04-rc1-00004-g5726295 (Apr 01 2012 - 12:26:50)
Texas Instruments Revision detection unimplemented
OMAP SD/MMC: 0

U-Boot 2012.04-rc1-00004-g5726295 (Apr 01 2012 - 12:26:50)

## Booting kernel from Legacy Image at 80300000 ...
   Image Name: 3.2.13-x7

[ 0.000000] Linux version 3.2.13-x7 (root@panda-a1-1gb) (gcc version
4.6.1 (Ubuntu/Linaro 4.6.1-9ubuntu3) ) #1 SMP Tue Mar 27 12:03:52 UTC 2

This image is very old, as far as i can tell, atleast 3-4 months old..
Please retest with, something more recent from:

http://elinux.org/BeagleBoardUbuntu#Demo_Image

[ 5.640533] EXT4-fs (mmcblk0p2): INFO: recovery required on readonly
filesystem
[ 5.651580] EXT4-fs (mmcblk0p2): write access will be enabled during
recovery
[ 5.686767] JBD2: no valid journal superblock found
[ 5.695220] EXT4-fs (mmcblk0p2): error loading journal

Looks like your ext4 rootfs partition got screwed up, most likely
caused by a few "pull power plug" when system is running, or just a
crappy micro-sd card.

Regards,