[beagleboard] Angstrom USB Errors

I installed Angstrom on my BB but whenever I try to connect a USB
device (Bluetooth, Webcam, etc) it is not detected on my board. This
happens for EHCI and the OTG.

I checked my devices and they work on other computers. For the OTG I
used the mini A to USB converter as suggested.

This is what I get for USB EHCI when I "lsusb".

[ 282.920562] hub 1-0:1.0: Cannot enable port 2. Maybe the USB cable
is bad?
[ 285.998626] hub 1-0:1.0: Cannot enable port 2. Maybe the USB cable
is bad?
[ 289.076812] hub 1-0:1.0: Cannot enable port 2. Maybe the USB cable
is bad?
[ 292.154998] hub 1-0:1.0: Cannot enable port 2. Maybe the USB cable
is bad?
[ 292.162109] hub 1-0:1.0: unable to enumerate USB device on port 2

My BB specs:

Linux Kernel Version: Linux beagleboard 2.6.32
X Loader Version: X-Loader 1.4.4ss
U-Boot Version: 2010.03-rc1

I tried to check on here but nothing has helped so far. A side note,
I've not been able to update my BB using "opkg update" etc b/c I don't
have a USB Ethernet adapter, and even if I did, I don't think it would
work since USB isn't working.

I think I saw somewhere on here that it might be an issue that needs
me to patch something.

Help would be appreciated.

I had the same problems a while back. My problems went away when
updating to the latest Ångström packages.

    $ opkg update && opkg upgrade

I think it is a Linux (kernel 2.6.32) issue because I saw those problems
also on other machines.



That's what I suspected. I don't have my BB hooked up to the internet
though, I don't have a USB Ethernet adapter, how do work around this.

Is there a way to update it by transferring files on to my SD card?



You could download the relevant opkg files and copy them to the SD card and install them manually. Alternatively you could use Qemu to run an ARM emulator on your PC and have it do the updates. However, I doubt that would fix your problem. I doubt that both the EHCI and OTG ports have physically failed… There have been some issues with the EHCI port, but they are more intermittent issues / failures after high data transfers…

You haven’t said that you are using a USB 2.0 High Speed hub on the EHCI port which you must use if your devices are Low or Full speed…

If that isn’t the problem then try this: connect the BeagleBoard to a PC using a regular/normal USB cable. What does the “dmesg” command output after the BeagleBoard has finished booting…? If you see a CDC device has been found then you can use it to connect via your PC to the Internet to do those opkg updates. There are some instructions around, so Google for “bridge usb0 beagleboard”

The USB hub I have is defective. I tested the EHCI port with a USB
thumbdrive and it works fine for that. But when I plug in a Bluetooth
USB adapter or webcam into the EHCI port it fails, so that might be
the issue. However, the USB thumbdrive doesn't work on the USB OTG

I tried to manually download the opkg files, but I don't know what
files I need. I used this site: http://www.angstrom-distribution.org/repo/

I tried to bridge my Beagleboard with my Ubuntu computer but for some
reason it's just not working. This is getting really frustrating. Why
can't it just work straight out of the box. My project is due in less
than 2 weeks and I've spent the last 1 week trying to figure out this
issue to no avail.

What have you tried so far as bridging over USB to your PC’s network connection… that should be by far the easiest if the host PC is running linux… Can you provide “ifconfig -a” on both the BeagleBoard and the host and “dmesg” output (again from both).