[beagleboard] BBB upgrade fail

Yep. Everybody that has tried it has ended up where you are as far as I know. There are issues with it.

Three LEDs usually happens when you leave the SD card in after a re-flash or the re-flash has failed. It means the boot process is hung.

Re-flash it with the latest release.

http://circuitco.com/support/index.php?title=Updating_The_Software

Gerald

Thanks - just need to get me a uSD!

If you use SD formatter you should be able to recover the card and reuse it.

-Wil

I actually have that on the SW update Wiki, with links to the SD formatter SW.

Gerald

Oh ok cool.

-Wil

I guess if would have looked I would have seen that. Here is the link to the official one from SD association https://www.sdcard.org/downloads/formatter_3/ in case you want to link it too. It’s the one I use and it works pretty good on win 7 x64.

-Wil

Turns out I was dd’ing the compressed image :S My Ubuntu install wasn’t able to detect the SD card with that but I recovered it from Windows. Go figure…

That’s good to hear. Good luck with the reflash.

-Wil

Yeah I saw pages and pages of how to burn the image using windows and even mac but really no Linux example. That might be appropriate for a windows 8 embedded device manual but for the BBB - the shame! Here is the command I used

xz -cd BBB-eMMC-flasher-2013.05.20.img.xz > /dev/sdd

Oh please make sure that the sdcard is really /dev/sdd or you will hate me forever - sry

Just a warning, I found out that even after installing the most recent eMMC flash, never run opkg upgrade. I probably should’ve known that it was the upgrade itself that brings down the BBB, not the original image from which I am upgrading. It’s OK - one BBB reflashes while I play with the other.

Yep. Still not fixed!!

Gerald