[beagleboard] beagle bone / linux (unbuntu 12.04) noobie requesting help

New to bone and not yet up to speed on Linux either. I am probably missing
things which are simple and obvious to many, but not to me. I am using
ubuntu 12.04 on a desktop PC and for now at least would like to avoid the
additional complication of learning the differences of different
distributions.

I am not clear on what my options are for connecting with the as-delivered
angstrom image. With an ethernet cable connected, I can ssh
root@beaglebone.local, but this hangs after a while. I suspect this may be
because I am also connected to a local network and the ip address used by
the bone is also used elsewhere. The connection seems to persist when
disconnected from the LAN, but this is not practical for on-going
development. It's not clear to me how to connect using strictly USB or a
serial connection.

My immediate goals are:

1) Create an sd card with ubuntu from which I can boot and which I can
communicate with from an ubuntu development PC.
2) Run a simple application on the bone and see that it is working.
3) Eventually, communicate with it via a serial port.
4) Longer term, I have applications which run with mono on the desktop and
would like to be able to run these on the bone.

I followed the instructions at
http://elinux.org/BeagleBoardUbuntu#Precise_12.04_armhf

up to :

sudo ./setup_sdcard.sh --mmc /dev/sdc --uboot bone

and got:

"Unable to open folder for boot

No application is registered for handling this file"

This is an interesting bug, can you please pastebin your full terminal
log when you run this command?

What distro are you running on your development pc?

but this apparently created an image anyway. I tried it and it *looks like*
it is booting based on the LED activity, but I'm not clear on how to
connect. If

Note: Depending on your internal network these may work out the box
Apache, Port 80: http://omap/
SSH, Port 22: ssh ubuntu@omap
Getty, Serial Port

means I should be able to ssh ubuntu@omap with password 'temppwd', that
failed with:

ssh: Could not resolve hostname omap: Name or service not known

This is actually more dependent on your LAN's router/firewall and
doesn't always work.. (specially if you have more then one device with
the hostname 'omap')

I also tried ssh ubuntu@192.168.7.2, which times out.

Trying a browser with

http://opmap

takes me to a TI web site, unless I disconnect from the LAN/Internet, in
which case it tries indefinitely to connect to TI.

I retried burning the image with:

sudo ./setup_sdcard.sh --mmc /dev/sdc --uboot bone'

And in addition to the 'No application is registered' got a bunch of:

Warning: Unable to open /dev/sdc read-write (Read-only file system).
/dev/sdc has been opened read-only.

Ah, this is even weirder... Do you have another card? I need to see
the terminal log of what "setup_sdcard.sh"

I'm guessing that this is due to the card not being reformatted after the
first attempt. I have tried formatting with the mkcard.txt script from:

http://elinux.org/BeagleBoardBeginners

sudo ./mkcard.txt /dev/sdc

and I get:

dd: opening `/dev/sdc': Read-only file system
DISK SIZE - 3904897024 bytes
CYLINDERS - 474
/dev/sdc: Read-only file system

sfdisk: cannot open /dev/sdc read-write
./mkcard.txt: 37: ./mkcard.txt: kpartx: not found
umount: /dev/sdc1: not mounted
mkfs.vfat 3.0.12 (29 Oct 2011)
mkfs.vfat: unable to open /dev/sdc1: Read-only file system
umount: /dev/sdc2: not mounted
mke2fs 1.42 (29-Nov-2011)
/dev/sdc2: Read-only file system while setting up superblock

So at this point I would like to know (step by step?):

1) how do I force a re-format of the sd card
2) how do I create an image on it (did I leave something out previously?)
3) how do I confirm that the bone is booting from the newly burned sd card,
4) how do I connect to the bone when it boots from the new image?

The directions, work for about 95% of the people, unfortunally you've
found one of the 5% bugs..

Regards,