[beagleboard] Beagleboard, Ubuntu Wireless Issues

Hi Robert,

Sorry if this message comes through twice, I’m new to Google groups and I cannot tell if my post is simply taking a while or if it was not actually received (using email this time so I’ll have a record).

I’m running the 2.6.29-oer36 kernel. Plugging it in before or after boot does not seem to have an effect.

I’d also like to amend my previous email; In the best case the card will mount as USB0 but normally it does nothing. I tried several tests (results appended to this email) in an attempt to determine under what conditions it becomes available as USB0 but could not get it to appear even once (Although I did manage to cause a few kernel panics that I have saved and don’t know what do do with).

As for building it as a module instead of into the kernel; are there any disadvantages to moving all wireless drivers out of the kernel and into modules? From a functional stand point, I don’t understand the difference.

Please let me know if there is any more info you need or if I can help in any way. I’ve never built a kernel and this whole was meant to be (and has been) a good learning experience.

Christopher Prevoe

All trials done through ttyS2 (serial) and a Dynex powered usb 2.0 high speed hub
uname -a: beagleboard #2 Thu Jun 4 23:24:08 UTC 2009 armv7l GNU/Linux
To ensure the hub is not the issues, a 500mb flash drive is plugged into the hub and it showed up as /dev/sda every time
It is notable that the hub provides power to all devices even when the hub is not plugged into a computer (bb or desktop)

Trial 1: Device plugged into hub at boot up

  • lsusb does show the device as present
  • ifconfig -a does not show the device at all
  • Removing and replacing the device has no effect.

Trial 2: Device not plugged in at boot, hub plugged in at boot, once booted, log in then use hub

  • lsusb shows the device as present
  • ifconfig -a does not show the device at all
  • Removing the device then replacing it has no effect
  • Note: unplugging USB hub from bb resulted in a kernel panic; I saved the serial output on that one but have no clue what to do with it

Trial 3: Boot system without USB hub plugged in, boot, login, then plug usb hub in

  • lsusb shows the device as present
  • ifconfig -a does not show the device at all
  • Removing the device then replacing the device has no effect.
  • Note: unplugged USB hub from bb again but no kernel panic occurred

Trial 4: Plug USB hub into ‘desktop’. Desktop establishes a wireless connection fine. Boot and login to bb, then unplug hub from desktop and plug into bb

  • Kernel panic - saved

Trial 5: Retry trial 4 two more times

  • Kernel panic - seems the kernel panic in trial 4 is reproducible.

Hi Chris,

It looks like you aren't subscribed to the list yet. (it's manually
moderated for unsubscribers hence the sometimes 2-4 day delay)... So
i'm CC'ing you.

It'll be a couple days but i picked up the same wifi adapter from
newegg. I have another 802.11n adapter here but it just hard locks
the kernel. So hopefully we will get this issue solved..

As far as the external vs built in modules, here's a very simple
explanation. External modules give you a small "uimage" and the
ability to turn off/on the ability to load modules. However first
boot up can be a problem with the beagleboard, specially if your
rootfilesystem doesn't have the kernel-image and your network driver
is external. Although i have an idea for patching the ubuntu
rootfilesystem script. Built-in gives you a uimage that supports
everything, but it's bigger.