BeagleBoard Black user LEDs not blinking after connecting via USB


Today I bought new BBB, initially when I tried connecting it to my laptop using the provided USB cable everything went fine, I was able to login into it and access Angstrom.

Suddenly after sometime I couldn’t connect my BBB successfully.

Whenever I connect it via USB the power light is on whereas user LEDs are off.

Even windows 7 is not recognizing as mass storage device, instead it shows “AM335x USB” under ‘Other devices’ category in Device Manager.

In between I remember of trying to connect from ubuntu virtual machine from windows 7 host. Could this have cause any problem to the board?

Anantha Krishnan

Sounds like you unplugged the board without turning it off frist. Result could be a corrupted eMMC device.


Thanks Gerald, I will try flashing the eMMC device.

Anantha Krishnan

Hello Gerald,

I followed the procedure given here -

“10) Hold switch S2 (Boot Switch, see picture below) down by pressing on it and holding it while plugging in the power cable.”

  1. Whenever I powered on the board(with SD card) by holding Boot switch, nothing happened, only the power LED will be ON all other USER LEDs will be OFF, I tried holding boot switch for several minutes.

  2. Also, without holding the boot switch, if I insert SD card BBB will start flashing emmc and after about 45 minutes all four User LEDs will lit continuously.

I did point 2 several times, every time after 45 minutes the four LEDs will lit solidly but if it press POWER button turn off BBB, remove SD card and again power on BBB, it will not boot.

Instead four User LEDs will simply blink at a continuous pattern. I mean four LEDs will blink at once every second, in BBB irc someone said that after flashing it can take up to 30 minutes to boot, but I kept connected the board yesterday night completely for more than 8 hours still no luck.

Is this hardware problem or software problem?

Also, When I used image it booted properly from SD card, AGAIN I DID NOT PRESS BOOT BUTTON.

I am worried about two things,

  1. Why pressing BOOT button is not working as expected, in all docs this point is mentioned. Why it flashes or boots from sd card only without pressing boot button.
  2. Why I am not able to flash emmc with default Angstrom linux.

Anantha Krishnan


Im facing the same problem did you happen to know the answer ??


hello i also facing same problem can you please tell me solution for it

Hey guys,
Doubt this info will be useful to anyone 4/5 years past the date the asked question was asked, but for anyone in a similar situation I had the same problem as Anantha Krishnan. I am running on the BeagleBone Black rev C and in all scenarios the images taken from were completely ignored by the BeagleBone. With the micro SD inserted whilst holding the boot button (S2) and applying power (micro USB to USB), nothing happened. What did solve my problem was changing the software that I used to write my image on my micro SD card. Instead of using Win32DiskImager I changed to balenaEtcher. Whilst the writing of the image took roughly 5 times as long, as soon as I repeated the process it worked first time. Not sure whether I was in a special scenario and this would work for others but its defiantly worth a shot!

This still didnt flash my beaglebone, but I tried it and at least my beaglebone runs now (user leds flash again). So thank you for this comment. All the best