Beagleboard booting problems from SD

After creating the two partitions, I copied the files in the order
specified on the beagleboard page,
http://code.google.com/p/beagleboard/wiki/BeagleboardRevCValidation to
partition labled W95 FAT32(LBA)
MLO
u-boot.bin
u-boot-f.bin
ramdisk.gz
uImage.bin
boot.scr
x-load.bin.ift
normal.scr

Disk /dev/sdb: 2032 MB, 2032664576 bytes
255 heads, 63 sectors/track, 247 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Disk identifier: 0x112a1eb6

  Device Boot Start End Blocks Id
System
  /dev/sdb1 * 1 50 401593+ c W95
FAT32 (LBA)
  /dev/sdb2 51 247 1582402+ 83 Linux

Command (m for help):

The instructions did not specify what files go to the respective
partitions. So, I just copied everything onto the FAT32 partition.
I just cannot get the beagleboard(Rev B7) to boot from SD card
(Selected the user button before the power is applied, every time).

I do NOT know what else to try.
This is frustrating. Please help.

Texas Instruments X-Loader 1.41
Starting OS Bootloader...

U-Boot 1.3.3 (Jul 10 2008 - 16:33:09)

OMAP3530-GP rev 2, CPU-OPP2 L3-165MHz
OMAP3 Beagle Board + LPDDR/NAND
DRAM: 128 MB
NAND: 256 MiB
In: serial
Out: serial
Err: serial
Audio Tone on Speakers ... complete
OMAP3 beagleboard.org #

You have an older board, with an older U-Boot.. That guide won't work
since it's expecting the Rev C U-boot to autoload the *.scr file.

From that previous link, Read: (How to flash x-loader and u-boot from
u-boot ) skipping the x-loader stuff re-flash this version of u-boot

1: http://beagleboard.googlecode.com/files/u-boot-f_revc_v3.bin

Note: nandecc sw was a later change, so just do both these to be safe:

nand ecc sw
nandecc sw

Otherwise check this youtube video out for how to setup U-boot PS,
http://www.youtube.com/watch?v=zymOmduNWyI&feature=channel_page

Regards,

Hi Robert,

Thanks for the response. Sorry, I did not mention that the files I
listed are all the Rev C versions that I renamed as follows.

The link I specified earlier indicated that the procedure was the same
for setting up both Rev B and C boards

MLO_revc_v3 - renamed as MLO
u-boot_revc_v3 - renamed as u-boot.bin
u-boot-f_revc_v3 - renamed as u-boot-f.bin
ramdisk_revc_v3 - renamed as ramdisk.gz
uImage_revc_v3 - renamed as uImage.bin
reset_revc_v3 - renamed as boot.scr
x-load_revc_v3.bin.ift - renamed as x-load.bin.ift
normal_revc_v3 - renamed as normal.scr

After inserting the SD card, I tried nand ecc sw but nothing happens

Yeap, that's fine... "nand ecc sw" was changed to "nandecc sw" in a
later version, it's perfectly safe to ignore that specific error.

Regards,

Hi Robert,
But, how do I get the board to recognize the SD card and boot from it?
Thanks,
Shankara G

You are not using the latest UBoot for Rev C. The audio tone message tells me that this is a Rev B version UBoot. You might want to consider switching to the newer UBoot.

Gerald

Hi Shankara,

You need to finish flashing that version of U-boot (1)

1: http://beagleboard.googlecode.com/files/u-boot-f_revc_v3.bin

Afterwords, U-boot should be looking for a "boot.scr" file on your SD
card for boot instructions..

Regards,

Sorry guys, I am really lost.

I tried flashing the u-boot.bin file(u-boot_revc_v3 - renamed as u-
boot.bin ) but I cannot go beyond this

Following the instruction in the section: * How to flash x-loader
and u-boot from u-boot

I think your missing "mmcinit"

from your fat32 paritition:

wget http://beagleboard.googlecode.com/files/u-boot-f_revc_v3.bin
mv u-boot-f_revc_v3.bin u-boot.bin

Stick SD card into Beagle and boot:

mmcinit
fatload mmc 0 80200000 u-boot.bin
nand unlock
nandecc sw
nand ecc sw
nand erase 80000 160000
nand write 80200000 80000 160000

Regards,

Hi Robert,

You are absolutely right, mmcinit was missing. I was able to flash
with the rev3 and this time, it booted from the SD.

The video link that you sent earlier (Demo by Digikey) sets some env
variables. Why do we need that? Are there any other pointers that you
prsonally thought may be useful?

I appreciate all of your time very much. Hopefully, I can start
learning something, now.

Regards,
Shankara G

Basically, those are the commands boot.src is actually using to boot
your system.

Note: that boot.src only works with that version of U-boot, if you
upgrade later, you'll have to manually setup your bootcmd & bootargs
just like the video shows..

Regards,

Thanks very much. I appreciate your patience and the much needed help
Regards,
Shankara G