Beagleboard C4 NAND recovery

I saw that this problem has been faced by many people in the past and
went through lot of threads on it.
My C4 beagleboard sends only 40W to the terminal when powered up. This
is with or without SD card, with or without USER button pressed.
I have tried making a bootable SD card in different ways.
I tried using the HP tool, using gparted, using commandline fdisk.
I also made sure that the FAT32 partition is set to bootable and the
MLO file is copied first.
I also tried using the MLO recovery file.
I tried the scripts by Robert Nelson too.
But none of these methods is giving any success in the problem.
Can someone please help me? Any more clue what can be going wrong?

Now I am trying recovery over UART using nishanth menon's tools
pserial / pusb. But I could not find the recovery script which was
mentioned in the old threads. (
I am confused at some points. I understand that I need to transfer the
x-load.bin file over UART / USB but I am not finding the precompiled
binary for this. Do I need to build this file? Then which toolchain
should be used for this? Any link to the toolchain binary or the
toolchain also needs to be built?

When I try the pserial it shows ASIC ID as 0x00 00 00.... (All zeros)

Please guide me..

Thanks and Regards,

What exactly is the problem? Resetting to factory status? Making a bootable disk? If recovery is the aim, use the manual steps provided by Robert. If you want to create a bootable disc with an OS, use one of those with a script that automates the process or you may spend months trying to mount/unmount the SD if using Ubuntu.

Here’s some advice I got for installing Ubuntu on a Rev C2, the grandfather of the C4, that worked:

Once you get to this step: “sudo ./ --mmc /dev/sdX
–uboot beagle”

Sorry if I was not clear in my previous post. The problem is I am not
getting to the U-boot prompt at all. The beagleboard is only sending
40W to serial console. This means, it is neither reading from NAND,
nor from the SD card. Or that there is some mistake I am doing in SD
card preparation.

Once u-boot prompt is reached, manual or automated method can be
followed to erase and write to the NAND, the x-loader, bootargs etc.

I think you may also need to post to the group more info, such as how you’re powering the board: direct 5.5, a powered hub or a host.


I am powering it with an external 5V, 2A adaptor. The serial port is
connected using an Everex pass through cable with 1:1 mapping and then
a cross cable (null modem cable) is used to connect to the host.
There are no other connections.
I just tried with another SD card too, but no success. I don't have
another beagleboard to try out.

If you press the USER button then the NAND is not utilized and no boot
from it. Either your board is dead (SD card is not powered properly)
or SD card is not correctly prepared.

BTW 40W is a very good message because it shows that at least the CPU is alive.

Yes, that's why my hopes are alive since it is sending 40W. Can it
happen that CPU is getting power but some other sections are not?
I will try to find out if SD card is not being powered up and if it's
connector has been damaged.

just check for 3V at the respective pin at the SD connector

One thing I observed was that if the USER button is not pressed, the
40W printing took some time (indicating that CPU was trying to find
some boot code in NAND) and when the USER button was pressed while
resetting the 40W was being printed immediately. This indicated that
SD card is not being detected by the CPU so I further did some
hardware testing and found some things as below:

1. There is no supply voltage (3V) at the SD card connector pins.
2. SD DET pin shows something about 0.7V when SD card is not inserted
and goes to 0V when inserted. The 0V is expected as it shorts the pin
to ground when card is inserted but when the card is not inserted, it
is pulled up to 1.8V. So I further checked some voltages at the test
points as per schematic.
3. Voltages found to be in line with specifications are:
VBAT = 4.14V
VDD1 = 1.2V
VDD2 = 1.2V
VDD_PLL1 = 1.8V
3.3V rail = 3.27V

4. Following voltages showed some errors:
VDAC_1V8 = 0V
VDD_PLL2 = 0.2V
VMMC1 = 0V
VIO_1V8 = 1.0V

5. Voltage across J2 is observed to be 0.1V indicating current draw of
1A. I doubt this is normal value?

6. Also the board heats up little more I guess. Since I do not have
any comparison board, I can not say this heating is regular or not,
but based on the voltage errors as observed above, it seems there is
some hardware problem occurred.

Probably, due to overcurrent, some LDOs are operating in protected
mode and hence their outputs are being shut down.

Further observation: The resistance between VIO_1V8 and ground is seen
to be only 1.4 Ohms indicating a short circuit somewhere. It's
difficult to find out the short circuit, probably the PMIC is damaged
(only a wild guess).

Is it time to go for a RMA now?

Share your observations with the folks at the Beagle hospital.


Can those people be contacted on email? Or a RMA only?

However you need to. Contact info is in the documentation.

Ok. Contacted. Waiting....
Thanks for help here!