[beagleboard] Cannot browse to http://beaglebone.local !! Worked the first day then stopped?

Hi Guys,
So Im new to BeagleBone and am having a strange problem. The first day I
had it I was able to go to beaglebone.local and get the Bone101 slideshow. I
dont believe I made any changes but then was unable to get back to this
page.

I can SSH in, also Cloud9 is running on :3000 (but not working currently -
will post seperate thread).

I havent tried a fresh sd-image yet, although I did try running opkg
update/install- but this was after I lost services on :80

Any help would greatly appreciated. Im fairly comfortable with Ubuntu but
this is my first swim in Angstrom.

Can you let us know what version of Bonescript you are running? 'git
log | head -3' would be enough for that.

A general 'dmesg' log would be helpful, along with the output of
'systemctl status bone101.service'. I think there is a way to fetch
the bone101 service log, but I always debug by shutting down the
service and logging the output to a live interactive terminal session.

Anyway, the server on :80 is exactly bone101.service. If the
beaglebone.local avahi service is good to get the right IP address,
then the bone101 service itself must be to blame.

As with my issue regarding the Cloud9 error (https://groups.google.com/d/topic/beagleboard/JA161TX_W6o/discussion) - this issue was also resolved when I re-imaged my SD card.

Still helpful info in your reply!