[beagleboard] Can't connect to USB serial port (FTDI module isn't loaded, ttyUSB device isn't created)

I know for the evm335x (Sitara) I saw a note no virtual OS drivers emulation is too slow

I was also told not to ask for help on here when building from vmware its not opensource either (-:

— On Mon, 5/13/13, Mike Mogenson michael.mogenson@gmail.com wrote:

> From: Mike Mogenson michael.mogenson@gmail.com
> Subject: [beagleboard] Can’t connect to USB serial port (FTDI module isn’t loaded, ttyUSB device isn’t created)
> To: beagleboard@googlegroups.com
> Date: Monday, May 13, 2013, 3:25 PM
> I’m having trouble connecting to the USB serial terminal of my new BeagleBone Black with the stock version of Angstrom that shipped on the board. I’m running a virtual machine of Ubuntu 12.04 LTS 32bit in VirtualBox on Windows 7 Pro 64 bit. I’ve installed the USB 2.0 drivers from the VirtualBox extension pack, I’ve disabled auto-mounting USB devices in Windows 7 by entering “mountvol /N” in the command prompt, and I’ve attached the USB Device “Circuitco BeagleBoneBlack [0308]” to the virtual Ubuntu machine.
> If I run “lsusb” in Ubuntu I see “Bus 001 Device 007: ID 1d6b:0104 Linux Foundation Multifunction Composite Gadget” however no ttyUSB devices are created so I ran the mkudevrule.sh script from /media/BEAGLEBONE/Drivers/FTDI, logged out and reinserted the BBB. Still no ttyUSB entries in /dev. I noticed that the mkudevrule script is for a USB vendor id of 0403 and product id of a6d0 but the BBB entry in lsusb has a vendor id of 1d6b and a product id of 0104. So I changed them in the udev rule, reloaded the udev rules, logged out for good measure, and reinserted the BBB. Still no ttyUSB entries in /dev and no ftdi_sio or usbserial module in lsmod.
> I decided to do things manually. I entered “sudo modprobe ftdi_sio vendor=0x1d6b product=0x0104”. This loaded the FTDI module but didn’t create the ttyUSB entries in /dev. I checked “cat /proc/devices | grep -i ‘ttyUSB’” which gave me “188 ttyUSB”. I then checked “sudo cat /proc/tty/driver/usbserial” which gave me “usbserialinfo:1.0 driver:2.0” but no entries for FTDI serial devices.
> At this point I’m admitting I’m stuck. Does anyone having any advice on how to access the USB serial port of the BeagleBone Black? Is my assumption about the different USB vendor id and product id correct? Am I (hopefully) missing something really trivial that will make this all work?
> –
> For more options, visit http://beagleboard.org/discuss
> —
> You received this message because you are subscribed to the Google Groups “BeagleBoard” group.
> To unsubscribe from this group and stop receiving emails from it, send an email to beagleboard+unsubscribe@googlegroups.com.
> For more options, visit https://groups.google.com/groups/opt_out.