[beagleboard] Compiling openssh instead of dropbear

Hi,

I am trying to compile “openssh” package to the rootfs using OE for angstrom distro. But not successful so far.

This is what I have done:

  • Add this line to /recipes/images/console-image :
    ANGSTROM_EXTRA_INSTALL ?= “openssh”
  • Then I run:
    bitbake console-image.

The compilation was successful, but the openssl package is not compiled into the rootfs.
I think that was because the “dropbear” package will be compiled by default, and therefore openssh was rejectected.

Can anyone help how can I config the OE so that “dropbear” will not be compiled but compiled “openssh” instead ?

  • Thomas

Replace ?= with = and try ‘openssh-sshd’ if you want to use the openssh sshd as server.

regards,

Koen

Thanks, but the system still using dropbear, instead of openssh-sshd.

These are what I had done:

ANGSTROM_EXTRA_INSTALL = “ppp netkit-ftp openssh-sshd”
$ bitbake console-image.

Do I miss anything ?

  • Thomas

Hey, I'm trying to get the zd1211 wifi driver to work on beagle. It seems there are a lot of incompatibilities with newer kernels in general. Did someone get it to work? Are there patches around? Unfortunately I found nothing appropriate.

I'm using 2.6.29 with "angstrom-2008.1". "bitbake zd1211" results in errors and the log-file presents a lot of kernel incompatibilities such as:

<--- snip --->
zd1211-driver-r85/src/zd1205.c: In function 'zd_writel':
zd1211-driver-r85/src/zd1205.c:704: error: 'struct net_device' has no member named 'priv'
<--- snap --->

But it is quite a lot, since I thought someone might have a patch for it or at least knows where I could find one.

Best regards

Sascha

Did you ever get a resolution to this? I have the exact same problem
as seen in the log file - no member named priv.

rob tow <robtow@tauzero.com> [2010-01-27 18:29:46]:

Did you ever get a resolution to this? I have the exact same problem
as seen in the log file - no member named priv.

It's because of the new kernel, in which there's not priv member in net_device
struct, but ml_priv. Maybe you can try with this patch[1], which is for 2.6.29
AFAIK.

1. http://lists.pld-linux.org/mailman/pipermail/pld-cvs-commit/Week-of-Mon-20090330/237162.html

-- ynezz

Isn't the zd1211 driver upstream into the kernel already?

Koen Kooi <koen@beagleboard.org> [2010-01-28 10:16:16]:

Isn't the zd1211 driver upstream into the kernel already?

Indeed. I was just telling him, why it's problem to compile it.

-- ynezz

If there was a working zd1211 driver in the Angstrom "deo" image. I'd
be happy. Or if I could compile from OE / bitbake I'd be happy, either
one.

If there was a working zd1211 driver in the Angstrom "deo" image. I'd
be happy. Or if I could compile from OE / bitbake I'd be happy, either
one.

Try disabling NetworkManager in your image (e.g rename
/etc/init.d/NetworkManager to /etc/init.d/NetworkManager-disabled)

Reboot and your zd1211 dongle should be handled properly by udev. I'm
not sure what the root of the issue is -- other chipsets don't seem to
suffer this problem).

Steve