BeagleBoard/DSP Howto - Helps are needed

Farazv,

Sorry, my bad. I made the modules and modules_install in a wrong
directry which caused the error of "no target".

In the correct directory, I did
  make CROSS_COMPILE=arm-none-linux-gnueabi- ARCH=arm modules --> OK
but with some warning
  INSTALL_MOD_PATH=$HOME/MOD --> OK
  export INSTALL_PATH > OK
  make CROSS_COMPILE=arm-none-linux-gnueabi- ARCH=arm modules_install

OK

The modules are insatlled in $HOME/MOD/lib/modules/2.6.28-omap1/

What should I do to install the modules to the SD card for BeagleBoard
to use?

Best regards,

Paul

Paul,

Create a soft link “libbridge.so.2” to libbridge.so in your root file system.

regards

Jesslyn

boot, which I mentioned. Well that’s the story so far :slight_smile:
I really need to get the DSP working properly on Beagleboard and I’d
appreciate the help.

Faraz,

If you just need to do get DSP working even if with an older kernel like 2.6.27-omap1, I may be able to help you.

regards

Jesslyn

Jesslyn,

That'd be great, 2.6.27 would be good enough. I'd only need DSP and
UVC
drivers (which I had already in 2.6.22). looking forward to hearing
from
you.

Thanks,
--Faraz

hi. paul

as you modules had been compiled out, please copy you $HOME/$MOD/lib/modules/2.6.28-omap1/

to you root file system /lib/modules/2.6.28-omap1/ . wish you DSP can be run as quickly as much.

/favor

hi,all

Aren’t there any good howto tutorials to introduce the DSP seting up correctly?

More or less, it can be tested by many users, and not the one which is out of date.

any help and documents is welcome.

thanks

/favor

Are you implying that the one I wrote is "not good"? I just tried the
'outdated' instructions and it works just fine. Of course you need to
use 'v2.6.27-omap1'.

Is it not working for you? Then please specify what is not working.

Note that if you can't compile a vanilla 'v2.6.27-omap1' and make it
run, then of course the one with DSP patches wouldn't work either.
Same goes for 'v2.6.28-omap1' and my 'v2.6.28-tidspbridge' branch.

My guess is the problem is the Angstrom images expect an extremely
patched kernel. I'll try to provide a simple image, but in the
meantime Daniel Díaz is working on some recipes for Poky Linux AFAIK.

Hello!

[...]

My guess is the problem is the Angstrom images expect an extremely
patched kernel. I'll try to provide a simple image, but in the
meantime Daniel Díaz is working on some recipes for Poky Linux AFAIK.

Wow, that is timing -- I was just sending you an email about that.

I've written a small HOWTO on getting a basic image (based on
Poky/OpenEmbedded) with a Kernel that includes DSP Bridge, and with
some useful packages included, such as OpenMAX and GStreamer plug-ins.
It's here:
  http://elinux.org/BeagleBoard/Poky

(Please note I'm not subscribed to this list, so CC me if you have
comments about that wiki page.)

Greetings!

Daniel Díaz
yosoy@danieldiaz.org

This doesn't seem to work:

Faraz,

Should I give you the kernel image and DSP bridge drivers, or do you want help in building the kernel source I use. Either way, I can help you. By the way, I use the baseimage.dof from tiopenmax-0.3. And cross compiler I use is [1]. First DSP application I used is Felipe’s dsp-dummy application.

regards

Jesslyn

[1] https://www-a.ti.com/downloads/sds_support/targetcontent/LinuxDspTools/download/c6x/TI-C6x-CGT-v6.0.16-eval.bin

Hello!

Thanks, Felipec, for trying this out.

[...]

This doesn't seem to work:
---
git clone git://github.com/mturquette/meta-texasinstruments.git
git checkout ddiaz/gitomapzoom
---

I tried this instead:
---
git clone git://github.com/mturquette/meta-texasinstruments.git
cd meta-texasinstruments
git checkout -b gitomapzoom origin/ddiaz/gitomapzoom
---

Noted. Corrected on the wiki.

Still, I'm getting this:
---
bitbake omap-image-min-gst
NOTE: Psyco JIT Compiler (http://psyco.sf.net) not available. Install
it to increase performance.
NOTE: Handling BitBake files: / (0902/0902) [100 %]
NOTE: Parsing finished. 872 cached, 0 parsed, 30 skipped, 0 masked.
NOTE: Cache is clean, not saving.
NOTE: build 200903282049: started

OE Build Configuration:
BB_VERSION = "1.8.11"
METADATA_REVISION = "5728"
TARGET_ARCH = "i586"
TARGET_OS = "linux"
MACHINE = "netbook"
DISTRO = "poky"
DISTRO_VERSION = "3.2+snapshot-20090328"
TARGET_FPU = ""

ERROR: Nothing PROVIDES 'omap-image-min-gst' (but '[]' DEPENDS on or
otherwise requires it)

My bad. I missed a "/conf/" in the path of the configuration. Instead of:
  cp -p $POKY/meta-texasinstruments/conf/misc/local.conf $POKY/build/local.conf
should have been like this:
  cp -p $POKY/meta-texasinstruments/conf/misc/local.conf
$POKY/build/conf/local.conf

Wiki has been updated with your input.

Thanks and greetings!

Daniel Díaz
yosoy@danieldiaz.org

Hello Jesslyn,

It would be great if you can provide a package (for the BeagleBoard)
includes a uImage, a file system contains DSP bridge drivers and all
the stuff needed to run ping.out and Felipe's Example dsp node.

If I don't ask too much, a uImage plus a RamDisk file (rd-ext2.bin)
for DSP bridge driver and application would make beginners' lives
easier.

Of course I also like to know how to build the all things myself. But
I would like to have something working before heading the long
journey.

Best regards,

Paul

Hi Paul,

Follow this link for the kernel and root file system. Use the root file system over NFS. It saves a lot of time.

http://labs.embinux.org/index.php/TI_DSP_Bridge_Resources

  • Jesslyn

2009/3/29 <paulchainkang@gmail.com>

Jesslyn,

Thanks for providing the package of resources. I am kind of busy
today. Please allow me to update you the test results tomorrow.

Best regards,

Pauk

hello,

I'm using the latest files from http://www.angstrom-distribution.org/demo/beagleboard/
on a B5 beagleboard, I've tried to follow the steps you mentioned but
in steps 4 and 6 I got the following output:

(gst-launch-0.10:1604): GStreamer-WARNING **: Failed to load plugin '/
usr/lib/gstreamer-0.10/libgstsubparse.so': /usr/lib/gstreamer-0.10/
libgstsubparse.so: undefined symbol: parse_sami
CMEM Error: init: Failed to open /dev/cmem: 'No such file or
directory'
Setting pipeline to PAUSED ...
Pipeline is PREROLLING ...
Pipeline is PREROLLED ...
Setting pipeline to PLAYING ...
New clock: GstSystemClock
Got EOS from element "pipeline0".
Execution ended after 26000976 ns.
Setting pipeline to PAUSED ...
Setting pipeline to READY ...
Setting pipeline to NULL ...
FREEING pipeline ...
(EE) omapfb(0): FBIOBLANK: Invalid argument
(EE) omapfb(0): FBIOBLANK: Invalid argument

no video is shown, X is still running, and I'm about to scream...

I've tried using the following commands as recommended in
http://groups.google.com.mx/group/beagleboard/browse_thread/thread/0a88dccbb7acc06c?hl=es#
but I got a different error and no video.

modprobe cmemk phys_start=0x88000000 phys_end=0x89000000
pools=20x4096,8x131072,5x1048576,1x1429440,1x256000,1x5250000,3x829440
modprobe dsplinkk
modprobe lpm_omap3530

Does somebody have an idea of what could be the problem???

B.R.
Oscar Arias

Jesslyn,

My SD card stops working maybe due to too many re-writes. I need to
get a new SD card. So I will update later, sorry.

Best regards,

Paul

hi, on the link , i can’t see nothing.

http://labs.embinux.org/index.php/TI_DSP_Bridge_Resources

does it? or something else is wrong?

Hello Jesslyn,

Finally, I got my new SD card. And I got ping.out working finally.

I downloaded you package two days ago. SD card broken and could not
test until the new SD card arrived today. Bellow is my procedure..

1. Downloaded DSPBridgeResources.tar.bz2 from
http://labs.embinux.org/index.php/TI_DSP_Bridge_Resources. (but just
like Tang said, it is removed as I checked it today.)

2. On my Windows PC, I uncompress DSPBridgeResources.tar.bz2 with
WinRAR v3.7 to get uimage.dsp, target.tar.bz2 and README.

3. I run Utu 7.10 in a VMware Virtual Machine (VM) on my Windows PC.

4. Copy target.tar.bz2 to the Ubuntu VM, /home/jars/tmp.
       $ bunzip2 target.tar.bz2
       $ sudo tar xvf target.tar
   Then I get /home/jars/target

5. Make a RamDisk with 32Mbyte size
       $ dd if=/dev/zero of=rd-jessylyn bs=1k count=32768
       $ mkfs.ext2 rd-jessylyn

6. Mount the RamDisk and copy target/* to the root of the RamDisk
       $ sudo mkdir /mnt/jessylyn
       $ sudo mount -o loop rd-jessylyn /mnt/jessylyn/
       $ sudo cp -R target/* /mnt/jessylyn/
       $ sudo umount /mnt/jessylyn/

7. Gzip the RamDisk, then rename it to rd-ext2.bin
       $ gzip -9 rd-jessylyn
       $ cp rd-jessylyn.gz rd-ext2.bin

8. Copy the uimage.dsp in Step #2 and the rd-ext2.bin in Step #7 to
teh SD card. The card has files like
        2009/03/17 下午 05:50 16,740 MLO <--
downloaded from http://code.google.com/p/beagleboard/wiki/BeagleSourceCode
        2009/03/17 下午 05:50 717,372 u-boot.bin <--
downloaded from http://code.google.com/p/beagleboard/wiki/BeagleSourceCode
        2009/03/17 下午 05:49 9,808 x-load.bin.ift <--
downloaded from http://code.google.com/p/beagleboard/wiki/BeagleSourceCode
        2009/02/17 下午 08:42 1,819,728 uImage <--
copied from uimage.dsp of Step #2
        2009/04/02 下午 08:26 10,566,254 rd-ext2.bin <--
copied from rd-ext2.bin of Step #7

9. Plug the SD card to my Beagle board and boot up. Remember to stop
the autoboot by pressing a key. In the U-boot console, set the
bootargs as
        .............
        Audio Tone on Speakers ... complete
        Hit any key to stop autoboot: 0
        OMAP3 beagleboard.org # setenv bootargs
console=ttyS2,115200n8 ramdisk_size=32768 root=/dev/ram0 rw
rootfstype=ext2 initrd=0x81600000,32M nohz=0ff
        OMAP3 beagleboard org # printenv
        OMAP3 beagleboard.org # run bootcmd
        reading uImage

        1819728 bytes read
        reading rd-ext2.bin

        10566254 bytes read
        ## Booting kernel from Legacy Image at 80300000 ...
        ..............
        ..............
        mmc0: new SD card at address 616d
        mmcblk0: mmc0:616d SD01G 1006080KiB
        mmcblk0: p1

        [root@(none) /]#

10. Follow README (see Step #2), ping.out works like a charm.
        [root@(none) /]# ./bridgeinstall
        INFO: For help run script as ./install_bridge help
        /install_bridge: command substitution: line 38: unexpected EOF
while looking for matching `''
        /install_bridge: command substitution: line 39: syntax error:
unexpected end of file
        INFO:Installed Bridgedriver from current directory:/lib/
modules/2.6.27-omap1-05170-gdb2fd87-dirty/kernel/drivers/dsp/bridge
        [root@(none) /]# dynreg.out -r /lib/dsp/pingdyn_3430.dll64P
        [root@(none) /]# ping.out
        DSP device detected !!
        DSPNodeCreate succeeded
        DSPNode_registerNotify succeeded
        DSPNode_run succeeded
        Ping: Id 1.000000 Msg 0.000000 Mem 2408232.000000
        Ping: Id 1.000000 Msg 1.000000 Mem 2408232.000000
        ........................
        ........................
        Ping: Id 1.000000 Msg 48.000000 Mem 2408232.000000
        Ping: Id 1.000000 Msg 49.000000 Mem 2408232.000000

11. Felipe's dummy also works, but it will make the system in a loop
for a looooong time.
        [root@(none) /]# dynreg.out -r /lib/dsp/dummy.dll64P
        [root@(none) /]# dummy
        DSPNodeCreate succeeded
        DSPNode_run succeeded
        dmm_buffer_map: 0x12008
        dmm_buffer_map: 0x12028
        running 14400 times
        dmm_buffer_flush: 0x12008
        dmm_buffer_invalidate: 0x12028
        dmm_buffer_flush: 0x12008
        dmm_buffer_invalidate: 0x12028
        ....................
        ....................

Finally, I got ping.out and dummy work, even the DSP system is not
built by myself. Thanks to all, especially to Jesslyn, Felipe and
Farazv.

Best regards,

Paul

Favor,

I had to take down the link due to request from TI. Apparently it contained the DSP firmware which were not re-distributable. I am involved some other work these days. Please give couple of days time to upload the root file system without the TI proprietary DSP firmwares.

regards

Jesslyn

Who contacted you?

Isn't the situation the same for dsp-link firmware that AFAIK is being
distributed in Angstrom images?
http://groups.google.com/group/beagleboard/browse_thread/thread/a88dccbb7acc06c