[beagleboard] flashing BBB with image made from /opt/scripts/tools/beag.... and getting kernel panic

^^ that should have been:

dd if=/opt/backup/uboot/MLO of=/dev/mmcblk1.......

Which means the "beaglebone-black-make-microSD-flasher-from-eMMC.sh" script
failed to get a network connect to grab a good bootloader:



I used microSD flasher script and got this issue:

version_message="1.20161216: more fixes..."


only a little out of date..

run git pull on /opt/scripts/


just did that, but now when i’m trying to run that script:

/opt/scripts/tools/eMMC/beaglebone-black-make-microSD-flasher-from-eMMC.sh: line 27: syntax error near unexpected token `<<<’

looks like local changes...

git reset HEAD --hard
git pull


after i did that, some more issues:

Tearing Down script environment
==> Unmounting /tmp
umount: /tmp: not mounted
==> Stopping Cylon LEDs …
==> Setting LEDs to
==> Force writeback of eMMC buffers by Syncing: /dev/mmcblk0
/opt/scripts/tools/eMMC/functions.sh: line 250: 32380 Terminated cylon_leds

that means it's done..


but after i tried to flash it on to another beaglebone, i got the following:

Begin: Loading essential drivers … done.
Begin: Running /scripts/init-premount … done.
Begin: Mounting root file system … Begin: Running /scripts/local-top … done.
Begin: Running /scripts/local-premount … done.
Begin: Will now check file system … fsck from util-linux 2.25.2
Checking all file systems.
Usage: mount [-r] [-w] [-o options] [-t type] [-f] [-i] [-n] device directory
Target filesystem doesn’t have requested /opt/scripts/tools/eMMC/init-eMMC-flasher-v3.sh.
Begin: Running /scripts/local-bottom … done.
Begin: Running /scripts/init-bottom … mount: No such file or directory
Could not copy file: No such file or directory
No init found. Try passing init= bootarg.

looks like a bug, copy the full serial boot log to



Pasted :


I tried creating an image two more times but i’ve been getting the same error/issue

so, while I’m able to create an SD card image for my build, when I try to flash another beaglebone by holding down the user button, the error occurs (as explained above). However, with one version of the SD card image, while the SD card is loaded and booted, I’m able to run /opt/scripts/tools/eMMC/init-eMMC-flasher-v3.sh and the eMMC flashes. I think there’s a bug somewhere while trying to execute that file. It’s odd because I ran the beaglebone-black-eMMC-SD-card-flasher code to create another SD card image, and I wasn’t able to boot from SD card.