[beagleboard] How to remove systemd safely and come back to sysvinit ?

In uEnv.txt

##Enable systemd
systemd=quiet init=/lib/systemd/systemd

You can comment out this whole line or remove the init=/lib/systemd/systemd bit to default back to sysv. A note here - I would just comment it out. Just in case you need it later, or you somehow muck things up by introducing Windows line feeds, etc.

As to the location of the file . . . This will depend on which rootfs you’re using. Newer rootfs’s will be single partition and the file will be in /boot maybe ? But you can use ls to look in /, or /boot. DO note there are two uEnv.txt files. A first stage, and a second stage. If the above line is missing from the file do NOT edit the file unless you know what you’re doing. As it is most likely the first stage file.

Anyway, changing

##Enable systemd
systemd=quiet init=/lib/systemd/systemd

to

##Enable systemd
#systemd=quiet init=/lib/systemd/systemd

Will do the trick.

with the default image ( *bone47 ) on a Rev C BBB, the second stage file is /boot/uboot/uEnv.txt. On the eMMC.

If you’re booting from an sdcard. Again like mentioned in my first post - It depends on which image you’re using. WIth single or dual partitions.

Note for the others out there … This will NOT work with Jessie images. Jessie requires sysv installed via APT, and removal of systemd via APT( or dpkg ) as well.