[beagleboard] monitor out of range + please somebody reply me

Please somebody reply me, I am stuck at my monitor problem!

Thanks,
Nastaran

Hi,

I am using a C4 Beagle board and Angstrom version 2.6.34 from
Antipasto Hardware Wiki [licensed for non-commercial use only] / BeagleTouch. The kernel
boots nicely and I can command it using my hyper terminal. However, I
still have two major problems.

First, I cannot use my DVI monitor for it. It is a W1952TE LG monitor.
It keeps giving me the “out of range” error. Its resolution is
1024x786. I have set the video arguments of my board using
Setenv dvimode “1024x786MR-16@60”.
I have also used lower resolutions and refresh rates; nothing works!

Just for clarification :
Have you changed the mode of Monitor from Analog to Digital ?

Hi,

I am using a C4 Beagle board and Angstrom version 2.6.34 from
Antipasto Hardware Wiki [licensed for non-commercial use only] / BeagleTouch. The kernel
boots nicely and I can command it using my hyper terminal. However, I
still have two major problems.

First, I cannot use my DVI monitor for it. It is a W1952TE LG monitor.
It keeps giving me the “out of range” error. Its resolution is
1024x786. I have set the video arguments of my board using
Setenv dvimode “1024x786MR-16@60”.
I have also used lower resolutions and refresh rates; nothing works!

Just for clarification :
Have you changed the mode of Monitor from Analog to Digital ?

Seems like it doesn't have analog mode. So no need to do any mode change .

Hi,

I am using a C4 Beagle board and Angstrom version 2.6.34 from
Antipasto Hardware Wiki [licensed for non-commercial use only] / BeagleTouch. The kernel
boots nicely and I can command it using my hyper terminal. However, I
still have two major problems.

First, I cannot use my DVI monitor for it. It is a W1952TE LG monitor.
It keeps giving me the “out of range” error. Its resolution is
1024x786. I have set the video arguments of my board using
Setenv dvimode “1024x786MR-16@60”.
I have also used lower resolutions and refresh rates; nothing works!

Just for clarification :
Have you changed the mode of Monitor from Analog to Digital ?

Seems like it doesn't have analog mode. So no need to do any mode change .

Dear Nastaran,

As per the monitor specification it's having two inputs D-Sub and
DVI-D am not sure about what's D-Sub( i think it's analog port only),
but for getting the beagle board display in monitor you should have
use the DVI-D and the monitor have to be in that mode.

Thanks for your reply.
Yes, I have done that. my boot arguments for video are as follows:

dvimode=640x480MR-16@60
omapfb.mode=dvi:640x480MR-16@60
bootargs=console=ttyS2,115200n8 console=tty0 root=/dev/mmcblk0p2 rw rootwait oma
p.video_mode=640x480MR-16@60

I’ve also tried other resolutions like 800x600, 1280x1024, 1024x768, … and lower frequencies like @40, @20, etc.

And somewhere I’ve read that maybe the board has problems with wide monitors. So I switched back to the SyncMaster1750 SAMSUNG monitor that used to work for me before I reinstall my angstrom and restore he nand flash. This monitor also give me “not optimum resolution, recommended resolution:1280x1024” error.

Nothing works. What else can I do?

Bests,
Nastaran

nastaran nemati wrote:

Thanks for your reply.
Yes, I have done that. my boot arguments for video are as follows:
dvimode=640x480MR-16@60
omapfb.mode=dvi:640x480MR-16@60
bootargs=console=ttyS2,115200n8 console=tty0 root=/dev/mmcblk0p2 rw rootwait oma
p.video_mode=640x480MR-16@60 <mailto:p.video_mode=640x480MR-16@60>
I've also tried other resolutions like 800x600, 1280x1024, 1024x768, ... and lower frequencies like @40, @20, etc.
And somewhere I've read that maybe the board has problems with wide monitors. So I switched back to the SyncMaster1750
SAMSUNG monitor that used to work for me before I reinstall my angstrom and restore he nand flash. This monitor also
give me "not optimum resolution, recommended resolution:1280x1024" error.

did you try to run it at 1280x1024?

I have used an HDMI-DVI cable (the HDMI side to my beagle board and the DVI side to the monitor). And this SAMSUNG monitor does have both analog and digital modes and I have selected digital. In fact I get to see the Orange page of beagle before booting the kernel. But when boot it it goes to the error I mentioned.
And I am sure that the monitor and cable are fine, because they used to work fine before.

Bests,
Nastaran

Thanks for your reply.
yes, I’ve tried 1280x1024@60 and 1280x1024MR-16@60. neither does work.
just to clarify, when I go to my monitor’s menue it says:

Digital
51.6kHz 65Hz NN
1024x768

Is there something wrong?

Bests,
Nastaran

Yes, I have done that. my boot arguments for video are as follows:

dvimode=640x480MR-16@60
omapfb.mode=dvi:640x480MR-16@60
bootargs=console=ttyS2,115200n8 console=tty0 root=/dev/mmcblk0p2 rw rootwait
oma
p.video_mode=640x480MR-16@60

Pls check the output of cat /proc/cmdline from your hyperterminal ,
once your OS started.
It will return the bootargs which you have given while booting.
There might be a possibility that the bootarg entry is not reflected
in kernel and it may booting with some default parameter.

This is the response I get:

root@beagleboard:~# cat /proc/cmdline
console=ttyS2,115200n8 console=tty0 root=/dev/mmcblk0p2 rw rootwait omap.video_m
ode=640x480MR-16@60

Nastaran

nastaran nemati wrote:

This is the response I get:
root@beagleboard <mailto:root@beagleboard>:~# cat /proc/cmdline
console=ttyS2,115200n8 console=tty0 root=/dev/mmcblk0p2 rw rootwait omap.video_m
ode=640x480MR-16@60

so, you are running 640x480M...

Maybe a stupid remark, but do you really have a carriage return between “oma” and “p.video_mode”. This should not be the case.
You mention that here on this kernel command line and with the bootargs string. This return should not be there.

Greetings,

Han

Thanks. I did not put an enter there myself. It’s just because of the size of the console of my hyper terminal; it is small and breaks down long lines. I don’t think it would matter, do you?

Bests,
Nastaran

Yes, 640x480. Given that I have set the boot arguments with

(dvimode=640x480MR-16@60
omapfb.mode=dvi:640x480MR-16@60
bootargs=console=ttyS2,115200n8 console=tty0 root=/dev/mmcblk0p2 rw rootwait oma p.video_mode=640x480MR-16@60)

I guess it’s fine that cat /proc/cmdline gives me

console=ttyS2,115200n8 console=tty0 root=/dev/mmcblk0p2 rw rootwait omap.video_m
ode=640x480MR-16@60

and when I set arguments as follows

dvimode=1280x1024MR-16@60
bootargs=console=ttyS2,115200n8 console=tty0 root=/dev/mmcblk0p2 rw rootwait oma
p.video_mode=1280x1024MR-16@60
omapfb.mode=dvi:1280x1024MR-16@60

the cat /proc/cmdline command gives me

console=ttyS2,115200n8 console=tty0 root=/dev/mmcblk0p2 rw rootwait omap.video_m
ode=1280x1024MR-16@60

So I guess the env variables are being set just fine. And still… the monitor gives me the same error message.
Any idea what else I can do?

Bests,
Nastaran