[beagleboard] Not running at full speed when powered using USB on Ubuntu?

Try your "comparison" again, but this time with a utility that shows
the actual cpufreq speed, "cpufreq-info"... And not some one time
calculated value done early on bootup...

PS, you'll never get full speed till you get a real 5Volt DC power
supply... As there is not enough power available..

Regards,

So how does the "BeagleBone Black" know you "power supply" can provide
more then the "500mA" max provided by usb-if?

Regards,

It is not in the BBB manual because that is a fact. You can run at 1GHZ on USB, as long as you do not over load it with a bunch of stuff in the USB host or try to insert a cape.

and yes, the BBB deploys DVFS that allows the frequency to flow from 300MHZ to 1GHZ as needed. It idles at 300MHZ in Angstrom, until you give it something to do, then it can pop up to 1GHz.

Gerald

Hi Gerald,
This is “interesting news” (as in the old curse “may you live in interesting times”).

Those of us working on real time applications for the BBB would really prefer not to have the CPU clocks (and hence software execution times) be a moving target. From our viewpoint all that does is create jitter.

We’d much prefer to burn power to make heat and in exchange have the clocks be a nice stable, predictable frequency.

How can we disable any twiddling of the CPU clock frequency?

Dave

It is for power saving and it does give the part the chance to cool off. I don’t know the exact method, but you can disable it.

Gerald

Simple.. Rebuild your kernel with:
CONFIG_CPU_FREQ_GOV_PERFORMANCE=y
CONFIG_CPU_FREQ_DEFAULT_GOV_PERFORMANCE=y

and completely disable all other:
CONFIG_CPU_FREQ_GOV_*'s

Regards,