[beagleboard] OpenCV installation on Ubuntu 11.10 r6 - BBxM (Rev C)

Please expand on "OpenCV is not working yet"

http://www.catb.org/~esr/faqs/smart-questions.html#beprecise

Regards,

I'm using Code Blocks IDE to build and run my code currently on other
PCs.

On other PCs - with ubuntu 11.04:
1. OpenCV was installed following this guide http://www.samontab.com/
web/2011/06/installing-opencv-2-2-in-ubuntu-11-04/
2. Code Build & Run - by adding the following to the build options to
a
Code Blocks project by adding

- To "Linker settings -> Other linker options": `pkg-config
opencv --libs`
- "Compiler-> Other options": `pkg-config opencv --cflags`

As mentioned in http://opencv.willowgarage.com/wiki/CodeBlocks

I tried following the same steps to Ubuntu 11.04 (with OpenCV 2.2) on
Beagle Board - couldnt find libraries and code didnot compile
I followed previous guides (mentioned in earlier message) to install
OpenCV
2.3.1 on Ubuntu 11.10 - same issue

Help?

Note - Has it anything to do with the package "libtbb-dev" failing
to install - couldn't find this package when "sudo apt-get install
libtbb-dev" Although I checked and found this which is irrelevant for
BBxM:
*libtbb-dev *a library that helps you leverage multi-core
processor performance without having to be a threading expert. It
represents a higher-level, task-based parallelism that abstracts
platform details and threading mechanism for performance and
scalability.

Thanks.
-Seham

I'm using Code Blocks IDE to build and run my code currently on other
PCs.

On other PCs - with ubuntu 11.04:
1. OpenCV was installed following this guide http://www.samontab.com/
web/2011/06/installing-opencv-2-2-in-ubuntu-11-04/
2. Code Build & Run - by adding the following to the build options to
a
Code Blocks project by adding

- To "Linker settings -> Other linker options": `pkg-config
opencv --libs`
- "Compiler-> Other options": `pkg-config opencv --cflags`

As mentioned in http://opencv.willowgarage.com/wiki/CodeBlocks

I tried following the same steps to Ubuntu 11.04 (with OpenCV 2.2) on
Beagle Board - couldnt find libraries and code didnot compile

Then, you need to install these "missing libraries"

I followed previous guides (mentioned in earlier message) to install
OpenCV
2.3.1 on Ubuntu 11.10 - same issue

btw: in 2.3.1 is already packaged in precise (12.04)...
http://packages.ubuntu.com/precise/libcv-dev

sudo apt-get install libcv-dev

and i already have an image:
http://elinux.org/BeagleBoardUbuntu#Precise_12.04_armhf_testing

Regards,