[beagleboard] Re: Beaglebone Black won't boot from Micro SD, all LEDs remain lit

Robert,

I haven't actually written the Ubuntu image to eMMC yet (I have on the first
five BBB's but not on the sixth, I can't get past step 1 on the sixth).

This is my goal.
1. Get Ubuntu installed on a microSD card.
2. Configure the BBB to boot from the microSD WITHOUT pressing the boot
button every time it boots.

I really don't care what version of Linux is in the eMMC, I just want the
BBB to automatically boot from the microSD card. The BBB will be accessed
and rebooted remotely, without a human present to push the button.

Well, that's been the default setting for a long time with those image
i just posted a link to.. Just grab the "eMMC-flasher" first to update
the eMMC. Then any of the "microSD" card images will boot just fine
without pushing the boot button...

http://elinux.org/Beagleboard:BeagleBoneBlack_Debian#2015-07-06

I will look at the links you provided. Will the instructions on the links
you provided help me reach my goal?

Regards,

Robert,

I installed Ubuntu (not Debian), by following your instructions for copying the raw microSD image to the microSD card: http://elinux.org/BeagleBoardUbuntu#BeagleBone.2FBeagleBone_Black

Then I inserted the card in the BBB, held down the boot button while powering up, and it booted from the card. If I reboot, it boots from the microSD card, which is what I want. If I remove the card and power up, it boots from the eMMC.

Do I need to flash anything to the eMMC? The eMMC still has the default Debian. Since the BBB boots from the card as desired, maybe I don’t need to do anything to the eMMC.

I have one question. I will be using a XBee cape board that needs UART2 to be enabled. I will need to add a line like this to uEnv.txt:
optargs=capemgr.enable_partno=BB-UART2

I think I should add this line /boot/uboot/uEnv.txt in the eMMC, am I right?

I ask this because the microSD card has two copies, /uEnv.txt and /boot/uEnv.txt. The contents of these two files and the file in eMMC are different.

Thanks,
Tim

Robert,

I installed Ubuntu (not Debian), by following your instructions for copying
the raw microSD image to the microSD card:
http://elinux.org/BeagleBoardUbuntu#BeagleBone.2FBeagleBone_Black

Then I inserted the card in the BBB, held down the boot button while
powering up, and it booted from the card. If I reboot, it boots from the
microSD card, which is what I want. If I remove the card and power up, it
boots from the eMMC.

Do I need to flash anything to the eMMC? The eMMC still has the default
Debian. Since the BBB boots from the card as desired, maybe I don't need to
do anything to the eMMC.

I have one question. I will be using a XBee cape board that needs UART2 to
be enabled. I will need to add a line like this to uEnv.txt:
optargs=capemgr.enable_partno=BB-UART2

Okay, out of the box, that image shipped with 3.14.x, so you need to
downgrade to 3.8.x to use "capemgr.enable_partno=BB-UART2"

cd /opt/scripts/tools/
git pull
sudo ./update_kernel.sh --stable --bone-channel

I think I should add this line /boot/uboot/uEnv.txt in the eMMC, am I right?

Only edit /boot/uEnv.txt

cape_enable=capemgr.enable_partno=BB-UART2

I ask this because the microSD card has two copies, /uEnv.txt and
/boot/uEnv.txt. The contents of these two files and the file in eMMC are
different.

So /boot/uEnv.txt is the main script, /uEnv.txt is just there for
compatibility with old eMMC's..

If you look at /uEnv.txt closely, it reads /boot/uEnv.txt...

Regards,

Robert,

In your last post you suggested downgrading to 3.8.x so that I can use the capemgr to enable the BB-UART2-00A0.dtbo device tree overlay. But before I downgrade, is there an alternative way to enable UART2 that will work with 3.14.X?

I’m using an XBee cape board that needs UART2 enabled. Whatever method I use to enable UART2, it must work automatically at boot time so that my cape board works after booting without intervention from me.

By the way, I noticed that /dev/ttyO2 is present on my 3.14.X image, so I tried simply plugging in my cape board to see if UART2 worked, but no luck.

Thanks for you help,
Tim

Just use v4.1.x: (any jessie image (the console doesn't have the
dtbo's installed by default 1)

http://elinux.org/Beagleboard:BeagleBoneBlack_Debian#Debian_Image_Testing_Snapshots

Then in /boot/uEnv.txt add:

cape_enable=bone_capemgr.enable_partno=BB-UART2

Been hacking on it for the last few weeks, at this point it's
production ready. :wink:

1: https://github.com/beagleboard/bb.org-overlays

Regards,