[beagleboard] Trouble with buildroot and BBB

ethernet connection ? If so, try changing /etc/network/interfaces from dhcp to a static ip. Hard code it so you know which IP to connect to.

http://wiki.debian.org/NetworkConfiguration should give you a good starting point whether you’re using Angstrom, Ubuntu, or Debian.

One thing that I also have had problems with, which kind of doesnt make sense is changing /etc/resolve.conf → nameserver to point to your local router, if you infact have a router on your network. The only thing I can think of here, is that say if resolve.conf → nameserver is pointing to a different subnet, it may be looking for a dhcp server on this same subnet. shrug This doesn’t make sense . . . but its sometimes solved problems for me. As our local gateway / router hold DNS IPs for the outside world too. YMMV

If I'm not mistaken the netmask is supposed to be and the gateway is But I can't recall right of the top of my head. I can check when I get home this afternoon if you would like.


/etc/network/interfaces as copied directly from Robert Nelsons debian demo image how to:

auto lo
iface lo inet loopback

auto eth0
iface eth0 inet dhcp

Ethernet/RNDIS gadget (g_ether)

… or on host side, usbnet and random hwaddr

iface usb0 inet static

Paul, also for what it is worth. On Robert Nelsons guide here - > http://eewiki.net/display/linuxonarm/BeagleBone+Black He has some instructions on how to setup the usb0 g-ether device. It is for debian, and if you are using Angstrom perhaps you can read and adjust to make the same work on Angstrom. Personally, I do not know much about setting up usb0 for an ethernet connection., except that it is possible.

Being in the same boat as you with no serial adapter / module to connect to the bbb, once i got ssh working via ethernet, I called joy, and did not worry about the usb networking.