Beagleboard USB Modem hangs up

Hi, I recently got a Beagleboard and I'm workin with the usb modem
(gadget) to connet to internet with debian, I was workin fine, but I
needed some modules so I had to compile the kernel, I used cross
compilation succesfully, after that the internet connection in the
beagleboard suddenly hangs up, I have tested again some precompiled
kernerls but still the same.
I was looking at dmesg and found that when I first installed debian, I
got something like: "cdc_acm 2-1:1.2: ttyACM0: USB ACM device", now I
got "usb0: register 'cdc_ether' at usb-0000:00:02.0-1, CDC Ethernet
Device", the module for the usb modem changed, how can I use the
module that works, I mean ACM or how can I solve this?, please some
help, I'm really new in this sort of stuff.
Btw the connection only lasts around a minute, after that I have to
reboot the Beagleboard again.


I think I solved it, when I created the bridge and then restarted the
beagle, I just set again the bridge with the usb gadget, that was the
problem, now I eliminate the bridge and create it again and now it
works again.