[beagleboard] USB problem on C4?

Hi Gerald,

I also got 2 Beagleboards with ver. C4 last week. I guess the boards have the same EHCI problem. I am using USB-to-Ethernet. And, the Beagleboard connects to the NFS drive too.
During self-strap booting, I see non-terminated kernel messages on the terminal:
Starting Connection Manager
Running ntpdate to synchronize clock.
eth0: error fetching interface information: Device not found
udhcpc: no process killed
udhcpc: SIOCGIFINDEX: No such device
mount: RPC: Unable to send; errno = Network is unreachable

U-Boot version on both C3 and C4:
U-Boot 2009.08 (Oct 20 2009 - 13:09:07)

Do I need to put a newer version to Beagleboard C4? If the answer is yes, why the factory does not put the updated U-Boot version since the EHCI is relatively important hardware device?

Thanks in advance,

Your C4 is definitely out of date.. C4's from the Factory have:

So that explains the C4 ehci issue..


The C4 board does not have the same EHCI issue as was present on the Rev C2 and Rev C3. In order to take advantage of the fix you will need the new version of the UBoot to turn on the power to the USB PHY. The factory Uboot is one that will work. We test the boards before we ship them. The newer UBoot that is out there is no the one we are using in the factory and is not currently being put on the Rev C4 boards from the factory. I see from the printout you have provided, it is not the one from the factory.


Thanks Robert. After I read your message I checked the terminal messages one more time. If I have the SD card inserted, the U-Boot from the SD was loaded, which is the older version I have. But, if I removed the SD card, I got the up-to-date one: U-Boot 2009.11-rc1-00601-g3aa4b51 (Jan 05 2010 - 20:56:38).

Robert Nelson wrote:

That is how it works! Make sure you have the correct one on your SD card.


Yeap, it's a nice feature, upgrade u-boot without messing with nand
flash.... Just remember to save the latest u-boot.bin to your sd

The u-boot.bin form here works fine:


Thanks Gerald. But, the U-Boot in the NAND does not work for me because the u-boot in my SD card has custom patch to enable MMC2. So, I need to pull the proper u-boot version from git and apply the patch again. Or, I may just do the patch in the kernel driver instead.

Gerald Coley wrote:

Well, then it is up to you to be compliant with the required changes to make the EHCI port work.