[beagleboard] using 3G USB modem to connect to internet

Hi, I’m in need of some help.

I want to attach my Beaglebone to the internet using a 3G USB modem (e.g. Vodafone K3770).
I have the latest Ubuntu distro and Linux kernel.
I can see three GSM modems ttyUSB0-3 (using dmesg).
When I try to install wvdial it says that it is not available?

What’s odd… If your running the “latest” it’s already installed…


Other posts seem to use ppp but are not specific to ubuntu.

Can someone tell me the steps I need to take to get on line?


I have tried to re-build the kernel, just in case but I am stopped.
Can someone tell me what I'm doing wrong?

I went to: http://elinux.org/BeagleBoardUbuntu

Advanced Users only: BeagleBone Kernel v3.8.x source, used in these demo
images: https://github.com/RobertCNelson/linux-dev/tree/am33x-v3.8

git clone git://github.com/RobertCNelson/linux-dev.git
cd linux-dev
git checkout origin/am33x-v3.8 -b tmp

Everything was OK till I tried to build the kernel.
It asks me for dependencies one of these: ia32-libs will not install! as it
need ia32-libs-multiarch
But this is not installable (or so it says)!!

Okay so obviously, your not running the exact same system as me
(Debian Wheezy amd64), want to provide a few details, otherwise you
haven't provided any details on your host system for us to help you..

aka: lsb_release -cs etc..

Please help, I'm pulling my hair out.

Really after two days? Take a breath, otherwise your just going to burn out..


Does this allow the ia32-libs to be installed on your system..

sudo dpkg --add-architecture i386
sudo apt-get update
sudo apt-get install ia32-libs

btw, what does:

dpkg --version



Okay, so depending on how you install wheezy/quanta/raring,

dpkg --print-foreign-architectures is not always enabled to be i386...

So now i check that:

and request that you enable it...