[beagleboard] Windows 7 (64-bit) USB Device not recognized

Did you install the drivers from the getting stated page? This looks to me like the new Gadget serial device over USB that lets you connect a terminal to a COM port that comes from the board. It is a new feature in the latest release.


I run Windows 7 x64 Enterprise. I plugged in the USB, mass storage showed up almost immediately. I followed the getting started steps from the included START.htm file on the bbb, clicked the direct link for the CDC drivers, and networking over USB worked fine once the installer installed from what I can tell around 4-5 different drivers.

If all you see are some image files from the SD card, well, you without a doubt are not doing it right. If I may suggest, why not go to the following link, and follow the steps to create a card that flashes the eMMC.


After you have done this, you can then boot and install the drivers from the start.htm file, where you will find the drivers you need.


Glad you found a solution!