Beagleboard -Xm boot up

I had recently purchased a beagleboard Xm and trying to boot it up
using the steps mentioned at
. When i try to boot up using minicom nothing appears at the screen.
I am using a USB-serial converter and 5v power supply.
Neither do i see my board booting up nor anything else. Can anyone
tell me where am i going wrong.

Hi reshma - the first thing to look at are your minicom settings. Do a “sudo minicom -s” and then examine Serial port settings. Make sure you are listening to /dev/ttyUSB0, 115200 8N1, no hw or sw flow control. If you still get nothing, it is very possible your serial port is some other number, like /dev/ttyUSB1.

hope this helps!

looks like cable issue (null modem , IDC10-DB9).check the same as per mentioned in wiki.

amol - I don’t think so, as this is an xM board that does not require a null-modem cable. Most often, issues like this lead back to minicom settings. I know my host seems to randomly assign me to either /dev/ttyUSB0 or /dev/ttyUSB1, and sometimes I have to check dmesg to see where I should be listening.


It assigns TTYUSB1 if for some reason TTYUSB0 is locked or busy. Your
minicom settings should be as follows: 115200 8N1, No, No. I've been
using a straight DB9 with my xM as well.


Thanks, Alex - reshma is the one looking for help.

Hi All,

My minicom settings are right. I set them at 115200 8N1,No No. I checked my device also.,it is ttyUSB1. I initially used serial-usb converter and then later a straight cable as well but the same result. I am unable to understand where else am I going wrong.

I keep pressing my user button and still it is pressed I give the external supply… Is this procedure right?

With the xM there is no need to hold down the user button. The board always boots from SD.

It appears that your comm settings are correct. If you use a straight-through cable, set the serial port to /dev/ttyS0. If that doesn’t work, try /dev/ttyS1. At the very least, even with a bad SD card, or no card inserted, you should see …60… on the serial port.

(also… make sure it is /dev/ttyXXX, not just ttyXXX)

Jeff -
I do see 60 with few characters with SD card inserted, when i boot it with usb power alone although the board doesnt boot after that . But in the case of external power supply I just dont see anything on my screen.

It sounds like your external power supply is not providing the correct power. Make sure it is 5V with positive on the tip, negative on the barrel - make sure to measure it with a multimeter

I checked my power supply… That also works fine. I dont understand what is the issue here.

Hi all,

Finally with help of usb OTG, I was able to see my board boot but it does not boot fully and hangs. I dont know why it is reverting back to X-loader after running u-boot. Any help would really mean a lot,I have been desperately longing for my beagle board to boot. This is the output from my board

Hi reshma,

The board won’t boot reliably via OTG. I see from your other note that you have a bad power supply - the best thing to do is to fix or replace the power supply. You might try using a meter to determine the voltage it provides - you need 5V with positive in the center, negative on the outer barrel.

good luck!

Thanks for your help. I actually had a bad power supply,although it provided 5V when measured with multimeter . I bought a new one and tried and thankfully it worked :slight_smile:

Excellent, glad to hear you sorted it out

On that subject, is anyone using the Sparkfun 5V supply? They're pretty
cheap, but some of the comments suggest there's a reason for that. If
they work, I'm thinking I'll grab a couple. Anyone?


Iirc they had some odd issues with forged UL / CE stickers... I think its all over with by now. Be sure to check to make sure they're not over 5vdc before you plug it in.