BeagleBoard XM not booting up


I have been using the BBxm for the last 6-7 months. The last time I tried powering it on, it just stopped working.

I don’t think it even got to the Bootloader, because there was no output from the serial port.
Only the power LED is lit up. When I turn power on, an LED close to the USB and a red LED close to the power jack light up briefly.

I don’t think its a problem with the OS/ bootloader. Looks like a HW problem to me.

any advice/ suggested course of action ?


Have you tried recreating the SD card? Do you have a serial port printout that you can share?



There was no output at all from the Serial port ! It was blank.

If you remove the SD card, you should get some characters printed to the display.



I powered the BBxm without the SD card, and the output from the serial port was still blank.
I’ve copied what I get below the email - minicom starts and then there is nothing.


Welcome to minicom 2.4

Compiled on Jan 25 2010, 07:02:36
Port /dev/ttyUSB0

Press CTRL-A Z for help on special keys

Well, based on what you have told me, the board is totally dead. The only option is to request an RMA and let them try and figure out what is wrong with the board.


Thanks Gerald.
Will see what I can do.