BeagleBoard xM Rev C - Problem

The additional characters are perfectly normal, they appear because you must have set on your terminal emulator to show the non-printable characters. Then on this symptom i don’t think you have any hardware problem.
About not booting, probably there is something wrong with your sd card image.
Try to use a pre-built image, or better, the production image that comes with the board, available here:
http://circuitco.com/support/files/BeagleboardxM/xM_Rev_C_Production_4-25-2010.7z
If you made everything right and still have no boot, then you may have a hardware problem.
I hope it helps.
Regards,

Fernando

First of all thank you for your answer.
Ok, so the additional characters are no problem.
The prebuilt Image that you recommended me is exactly the one I used, so that should not be the Problem. Moreover I’ve also tried other Images with the same result…

Is there any other way to bood the Beagleboard xm, or if not - is there a way to flash the DM3730 Firmware?

Yes, there are other ways to boot the DM3730, i think the easiest, other than sd card, is serial. But it is a little annoying, because you have to find the proper boot file (for sd card we use the x-load, for serial it will be another, S-load i think), use some windows software to send this boot file over serial.
I saw one colleague do it, didn’t do it myself, but i saw it working.

Some information are here:
http://elinux.org/BeagleBoardRecovery

If it is a hardware-issue, what are my options? Or do I have to buy a new one…

I think you can do a RMA. The details are on this link: