BeagleBoard xM Rev C Ubuntu 11.04 Headless install can't detect Ethernet nor USB ports, please help


I'm trying to install Ubuntu 11.04 Headless Image on a BeagleBoard xM
Rev C but during the instalation process it cannot detect the Ethernet
port nor the USB ports. I followed the instalation instructions from:

Also I tryed to install Ubuntu 11.10 Server on the same board, and I
find the same problem again.

I followed the same installation procedures on a BeagleBoard xM Rev B
and it works fine, but on Rev C I found the issues reported.

Please help.

can you try latest P kernel on it?

- --

Hello Paolo,

I solved the problem last week by installing Ubuntu 11.10 Demo on Beagleboard, installing linux-image-2.6.38-13-omap and changing the booting kernel as described in:

I’m sorry, I would like to help, but at this moment I don’t have any BeagleBoard xM rev C availiable.

2012/1/16 Paolo Pisati <>

Can you give some details on the steps you took to install the linux-image-2.6.38-13-omap and changing the booting kernel? I have tried a few times but having trouble because I am a beginner.


First be sure the boot partition is mounted at /boot/uboot.
Second install linux-image-2.6.38-13-omap or whatever kernel you want
to use, and then:

sudo mkimage -A arm -O linux -T kernel -C none -a 0x80008000 -e
0x80008000 -n "$1" -d /boot/vmlinuz-2.6.38-13-omap /boot/uboot/uImage
sudo update-initramfs -c -k 2.6.38-13-omap
sudo mkimage -A arm -O linux -T ramdisk -C none -a 0 -e 0 -n initramfs
-d /boot/initrd.img-2.6.38-13-omap /boot/uboot/uInitrd