beagleboard XM, u-boot build (CFG_LOADADDR)

Hello all,

i've tried to boot up beagleboard XM with MLO, u-boot.bin and uImage built by myself.
but it seemed not working properly.

after this message. "Loading u-boot.bin from mmc"
it is supposed to run u-boot code as far as I know.

start_armboot() -> ((init_fnc_t *)CFG_LOADADDR)();

but the board got freezing after start_armboot().
it means there are no available instruction at CFG_LOADADDR.

how do I have to deal with it. I have no debugger using jtag.
please give me the way to solves it.


btw, I followed with guide

is there anyone to give me a bit of clue ??

when I use original u-boot.bin that is included in SD card, it works
fine with MLO and uImage made by myself.


Just copy MLO and u-boot.img, which are built from u-boot mainline
v2011.12, to the SD card and give it a try. Don't use a different
repository for u-boot and MLO.



Thanks Robert,

I built u-boot with below link. as you said;a=commit;h=cba9a894fdb1cb49b60fcd1d1d6919cbd7995dd5

and then I got this …

U-Boot SPL 2011.12 (Mar 12 2012 - 23:01:25)
Texas Instruments Revision detection unimplemented
timed out in wait_for_bb: I2C_STAT=1000
reading u-boot.img
spl: error reading image u-boot.img, err - -1

ERROR ### Please RESET the board

any other suggestion ?

It tells you it can't find u-boot.img.
Did you copy u-boot.img (and __NOT__ u-boot.bin) to the same partition
with MLO?

..."As far as I know we never had an undetected error." - Anonymous

My public pgp key is available at:

Hi Robert,
I am getting the same error and I made sure to copy the u-boot.img from:

I am still getting the same error.
Any help would be welcome.