Beagleboard xM usb disconnects

Thanks very much. It is really simple to implement.

Best regards,

  1. április 13., péntek 23:48:24 UTC+2 időpontban RobertCNelson a következőt írta:

Sorry, the Cap mode only applies to the classic Beagle revision
C1/2/3, so that doesn't apply to your xM C...

Can you please test:

If it works, please respond/(aka get involved) in this thread:

As the issue is pretty rare..


Hi Robert,

thanks for the reply. somehow i missed your reply till today.

I tried the latest 3.2.28.x14 today and it still happens. Does that contain the kernel patches in the 3.2.24 link that you sent?


No, it does not... (it's an xM only fix that currently breaks the
older Beagle Cx family)..


ok i will definitely try that for sure. Will keep you posted

I thought I would have the same problem, but in the end I recognized that the "USB EMI"-thing only happend when I tried to mux the uart2_rx pin. The reason for this is that its also the usb-reset pin.

Try Robert’s build few post back. It works for me in solving that problem.


Robert do you know if your patch has been pushed into mainstream?

Which Patch?

I’m using the “BeagleBoard Support from Simulink” and so I’m fixed to Ubuntu 11.04. The Kernel you posted solved the usb-disconnect issue for me. Thanks a lot.