BeagleBoard-xM + USB OTG + USB2Ethernet


In my project I don't have seperate USB HOST port and I am trying to
use USB OTG port as USB HOST.

I have made the USB OTG port ID pin to ground, connected the external
powered USB HUB on the OTG port. And system can detect the USB HUB,
Mouse, Keyboard and Trendnet TU2 usb2ethernet adaptor connected to
HUB. But when I tried to open a webpage from web browser I got below
errors and once this error happen none of the USB device on the OTG
port works. I tried other USB ethernet adaptor from asix ax88x77 but
results are same. Has anybody tried beagleboard OTG port as USB HOST
with usb to ethernet adaptor? Do I need to try different brand of USB
2 Ethernet adaptor? Any thoughts / suggestions?

[ 2372.780853] ------------[ cut here ]------------
[ 2372.785522] WARNING: at drivers/usb/musb/musb_host.c:172
[ 2372.793731] Could not flush host TX2 fifo: csr: 2003
[ 2372.798706] Modules linked in: bufferclass_ti omaplfb pvrsrvkm
sdmak lpm_omap3530 dsplinkk cmemk rfcomm ircomm_tty ir
comm irda ipv6 hidp l2cap bluetooth rfkill mt9d112
[ 2372.813903] [<c0040c40>] (unwind_backtrace+0x0/0xdc) from
[<c006d0f8>] (warn_slowpath_common+0x4c/0x80)
[ 2372.823364] [<c006d0f8>] (warn_slowpath_common+0x4c/0x80) from
[<c006d168>] (warn_slowpath_fmt+0x28/0x38)
[ 2372.832977] [<c006d168>] (warn_slowpath_fmt+0x28/0x38) from
[<c0342e68>] (musb_h_tx_flush_fifo+0x8c/0xcc)
[ 2372.842590] [<c0342e68>] (musb_h_tx_flush_fifo+0x8c/0xcc) from
[<c034327c>] (musb_start_urb+0x34c/0x7d4)
[ 2372.852111] [<c034327c>] (musb_start_urb+0x34c/0x7d4) from
[<c0343db4>] (musb_urb_enqueue+0x4c8/0x5a4)
[ 2372.861480] [<c0343db4>] (musb_urb_enqueue+0x4c8/0x5a4) from
[<c03222d8>] (usb_hcd_submit_urb+0x7f4/0x918)
[ 2372.871185] [<c03222d8>] (usb_hcd_submit_urb+0x7f4/0x918) from
[<c0314164>] (usbnet_start_xmit+0x1c8/0x2ec)
[ 2372.880981] [<c0314164>] (usbnet_start_xmit+0x1c8/0x2ec) from
[<c03ef8fc>] (dev_hard_start_xmit+0x230/0x310)
[ 2372.890869] [<c03ef8fc>] (dev_hard_start_xmit+0x230/0x310) from
[<c0401eb0>] (sch_direct_xmit+0x7c/0x1d0)
[ 2372.900482] [<c0401eb0>] (sch_direct_xmit+0x7c/0x1d0) from
[<c04020dc>] (__qdisc_run+0xd8/0x104)
[ 2372.909332] [<c04020dc>] (__qdisc_run+0xd8/0x104) from [<c03eccc4>]
[ 2372.917968] [<c03eccc4>] (net_tx_action+0xd8/0x10c) from
[<c0073744>] (__do_softirq+0xe8/0x1f0)
[ 2372.926727] [<c0073744>] (__do_softirq+0xe8/0x1f0) from
[<c0073890>] (irq_exit+0x44/0x98)
[ 2372.934967] [<c0073890>] (irq_exit+0x44/0x98) from [<c003b078>]
[ 2372.942901] [<c003b078>] (asm_do_IRQ+0x78/0x98) from [<c003bb44>]
[ 2372.950958] Exception stack(0xdf909f30 to 0xdf909f78)
[ 2372.956024] 9f20: dd952940
0000002e 00000001 00000000
[ 2372.964233] 9f40: dd952940 ffffff98 df81f000 df8927c0 df81f150
c034387c df8a0940 df8927c8
[ 2372.972473] 9f60: df909f78 df909f78 c0321050 c0321054 60000013
[ 2372.979125] [<c003bb44>] (__irq_svc+0x44/0xa8) from [<c0321054>]
[ 2372.988037] [<c0321054>] (usb_hcd_giveback_urb+0x98/0xf0) from
[<c034388c>] (musb_gb_work+0x10/0x2c)
[ 2372.997222] [<c034388c>] (musb_gb_work+0x10/0x2c) from [<c00845ec>]
[ 2373.005950] [<c00845ec>] (worker_thread+0x1d8/0x288) from
[<c0087e10>] (kthread+0x78/0x80)
[ 2373.014282] [<c0087e10>] (kthread+0x78/0x80) from [<c003c9dc>]
[ 2373.022644] ---[ end trace 510b9faf434aa3f5 ]---

I didn't see any response, Has anybody tried USB2ETHERNET on USB OTG port? I am stuck on this issue now as my board has only USB OTG port.

Any help / suggestions?