Beaglebone A6 + LCD7 cape + 3.1MP Camera cape (Lets try this again)

I totally butchered the last post. So I decided to start again.

I have the following
Beaglebone Rev A6
LCD7 Cape
3.1MP Camera Cape

I have the Beaglebone and the LCD7 cape working.

I added my Camera cape to the LCD7 cape in the correct slot and the system boots to the GUI, but the camera cape does not work. I follow the directions below. Seems hard to miss any thing, but is there something like a drive install in need to do? possible bad camera cape?

Thanks,
Thad

Required setup:

  • A BeagleBone 3.1MP Camera Cape
  • A BeagleBone (with supported software)
  • A BeagleBone LCD7 Cape
  • A 5V DC power supply (we recommend 5V - 2A)
  • A Stylus (optional)

Following the instructions below to start using your BeagleBone 3.1MP Camera Cape:

  1. Ensure the EEPROM addresses on the LCD7 Cape and 3.1MP Camera Cape are different.
    • Note: The EEPROM address is determined by the 2-bit switches SW1 on both LCD7 and 3.1MP Camera capes. Ensure these two switches are configured differently.
  2. Mount the BeagleBone 3.1MP Camera to the connectors labeled “Cape Installed Here”. Ensure BeagleBone is mounted to the other connectors.
  3. Ensure the micro SD card using with BeagleBone has latest Angstrom image.
  4. Power up the BeagleBone by connecting a 5V DC power supply to the DC connector of LCD7 Cape.
  5. The BeagleBone is now booting up. This process may take from 1 to 2 minutes. LEDs D3 and D4 on LCD7 Cape and LEDs D1 and D2 on the Camera Cape should be lit.
    • Note: For more information about LCD7 Cape, please visit its wiki page here.
  6. After BeagleBone finishes booting up, you should see a desktop with black background. This is the Angstrom desktop.
  7. Go to the system menu bar at the top, select Applications > Sound & Video > Cheese Webcam Booth to open the Cheese application.
    • Note: A stylus is recommended to use the Angstrom user interface on LCD7 Cape.
  8. A live photo preview should be displayed at the center of Cheese application window.
  9. To capture a photo, click the “Take a Photo” button inside Cheese application window

Can you try the latest Angstrom release for BeagleBone? 11-22-12 is the latest Angstrom factory release for BeagleBone. You can find the image file and instructions on how to write image file to SD card at http://circuitco.com/support/index.php?title=BeagleBone#Image_Files.

-Hieu

Downloading / Setting up the SD Card per the instructions… Just an FYI… the SD Card had a label on it that said 11-22-12. I am still going to download and remake the SD Card…

11-22-12 release has support for both LCD7 and 3.1MP Camera Capes. Can you log in as root and run the command below to see if the capes are detected properly?
dmesg | grep -i cape

Also, make sure the EEPROM dipswitches on the LCD7 and Camera Capes are set to different addresses and the boards are fully inserted.

-Hieu

Build current SD Card Image: 11-22-12
checked the EEPROM switches
[dmesg | grep -I cape] returns the following:

[ 0.100585] cape: pcm register
[ 0.251068] BeagleBone cape EEPROM: found eeprom at address 0x54
[ 0.251068] BeagleBone cape: Beagleboardtoys. BeagleBone LCD7 CAPE…, revision 00A3
[ 0.251098] BeagleBone cape partnumber: BB-BONE-LCD7-01.
[ 0.251098] BeagleBone cape: initializing LCD cape
[ 0.271636] BeagleBone cape: initializing LCD cape touchscreen
[ 0.272033] BeagleBone cape: Registering PWM backlight for LCD cape
[ 0.272033] BeagleBone cape: Registering gpio-keys for LCD cape
[ 0.302581] BeagleBone cape EEPROM: found eeprom at address 0x55
[ 0.302612] BeagleBone cape: Beagleboardtoys. BeagleBone 3.1MP CAMERA CAPE…, revision 00A2
[ 0.302612] BeagleBone cape partnumber: BB-BONE-CAM3-01.
[ 0.302642] BeagleBone cape: recognized Camera cape
[ 0.303253] Camera cape sensor is facing forward
[ 0.362640] BeagleBone cape EEPROM: could not read eeprom at address 0x56
[ 0.422668] BeagleBone cape EEPROM: could not read eeprom at address 0x57
[ 0.422668] BeagleBone cape: initializing mmc

My camera sensor has a jumper… the pictures on the web show the pins with no jumper. What is the correct placement of the jumper. And I have tried the sensor facing both forward and backwards. I have also removed the actual camera and replaced. The lights on the Camera cape on R55 and R56 are on solid.

Still no luck

Can you check the resolution inside the Cheese application?

You can change the resolution by go to the top menu Edit > Preferences and select something like 256x256 in the dropdown box.

-Hieu

The jumper should be on pin 2 & 3 of the 3-pin header. If you look at the other side of the PCB (where the 3-pin header is soldered), the pin with a square hole is pin 1.

-Hieu

That was it… the resolution was 2048X1536. Moved it to 256x256 and got a picture! I totally missed the preferences! Thanks!

Thad