Beaglebone AI-64 can not boot both from eMMC and mircoSD card

Hi, everyone, I got my new Beaglebone ai-64, at the beginning, it can boot from eMMC, and i want to to use a new image TDA4VM Debian 11.3 2022-06-14 10GB SD XFCE, i follow the getting start guide, after flash the image in the microSD, and plugin to board, the board is no any reaction, the power light is light and LED1 is blinking, i use a Type-C connect to my laptop, and did not see any new ip address been assigned, (normal would have,, i am not sure it boot or not, and i think is not boot, so i follow this post and use the command after boot from eMMC

debian@BeagleBone:~$ sudo enable-beagle-flasher 
[sudo] password for debian: 
Created symlink /etc/systemd/system/ → /lib/systemd/system/beagle-flasher-init-shutdown.service.
log: enable-beagle-flasher
log: media is now setup to flash other media
log: [cat /boot/firmware/extlinux/extlinux.conf]
label Linux eMMC
    kernel /Image
    append console=ttyS2,115200n8 earlycon=ns16550a,mmio32,0x02800000 root=/dev/mmcblk0p2 ro rootfstype=ext4 rootwait net.ifnames=0 init=/usr/sbin/init-beagle-flasher
    fdtdir /
    initrd /initrd.img
log: Shutdown system and this flasher will run on next startup

after reboot, the board with sd card have power light on and LED1 blinking, but no ip address assgin to my laptop, and plug off the sd card, the board have power light on and LED1 light on without blinking and not boot success.

Any one have idea how to fix this problem?

The only real way to diagnose boot failures is to connect a USB-to-Serial cable to the port labeled “UART0” (mini jst-style connector). Connect to PC then apply power and see boot logs.

Alternatively, you can download a flasher image from here and follow this procedure.

  1. Create SD Card from above image and insert into Beagle.
  2. Power on Beagle while holding ‘boot’ button
  3. Release boot button after few seconds
  4. You should see LED lights moving back and forth in pattern like they are “running”
  5. Allow lights to finish and finally turn off.
  6. Reboot Beagle.

And if the image success boot, It is all the version of the image would automatic assign the IP address to laptop via Type-C cable?

HI @BarryBeagle

I have tried use the flasher image, after i follow your steps, i just got the Power light and LED1 light blinking like normal boot, but still no assign ip address( to my laptop, and can find the USB device when i check by

ls /dev/ttyUSB*
ls: cannot access '/dev/ttyUSB*': No such file or directory


Hi, @RobertCNelson
yeah, i try, but still not find the ttyACM, I use the Type-C to connect, but the strange thing is I think the flash image did not work for me, when it boot, only have the LED1 blinking, if the board began to flash the image to eMMC, as @BarryBeagle mention the lights would moving back and forth in pattern like running.

Just grab the latest “flasher” monthly snapshot: Debian 11.x (Bullseye) - Monthly Snapshots (ARM64)

Since the play is out, i’ll be updating the ‘recommended’ on April 1st, just waiting on one pdf…



I had a similar issue with my AI-64 not being able to boot from ‘flasher’ image.

My resolution was using serial debug cable and pressing “SPACEBAR” upon boot to halt boot process.

Then I was able to manually boot from EMC0 or EMC1 (I forget which), but this then kickstarted the flash program to run which resulted in having a factory reset board.

Once you get the debug cable working, you will see that uboot has a menu structure (I think you can issue an ‘help’ command to see all commands) then using that I was able to issue one of the boot commands with appropriate parameters to force it to boot from one of the EMC’s

Hi, everyone

I finally found is the mircoSD card problem, i change one(sandisk extreme pro 128 GB )and it work, just make sure yours sd card is high performance, for me “Kingston 32GB 31626-007.A000LF” is not working(but it work in beagelbone black)
now it boot successfully.


1 Like


i want to ask the component of the image, what is the version of TI Processor SDK in the BBAI-64( Debian Bullseye Xfce Image 2023-03-10) image?