BeagleBone and Bluetooth

I have been trying to get the beaglebone and a bluetooth dongle to work together. The beaglebone does reconize the bluetooth device but when I try to bring the state up I get a statment saying that RF-KILL will not allow it. I see the rfkill proccess in lsmod and the bluetooth device. I have tried the command “rfkill unblock all” and it cannot reconize the command. I checked in the /dev folder and rfkill is in there and i tried going into that directory and typed “./rfkill unblock all” and I get a permission denied. I cannot figure out how to go about this. Thank you for the help in advance. I did check the other post and none had a solution that helped at all.

The rfkill command line tool is not installed by default, use opkg
install rfkill
If it can't unblock the bluetooth device, check if it's blocked by
connman in /var/lib/connman/settings

Yeah i thought that would be a problem but opkg install rfkill didn’t work. It couldn’t find a package for it. I looked in the /var/lib/conman/settings and the bluetooth is enabled false but doesn’t that change when you bring up the interface.

I changed the setting to true and now I get either and rx error or timeout error.

Were you able to resolve this? I have tried two separate adapters in my Beagle Bone and no love. One is a $30 Kensington and the other is a generic $10 one.

If they are usb bluetooth dongles i had to recompile the kernel with usb DMA disabled. only then would the bluetooth would work.

Even that isn't always true, my bluetooth dongles don't work in either scenario :frowning:

My dongles don’t work either using the 3.2.21-psp15 kernel on ubuntu. rfkill says it’s unblocked but “hciconfig hci0 up” will time out and dmesg says “Bluetooth: hci0 command tx timeout”

How did you change the false to true

Did you ever get this to work?

The ASUS Bluetooth dongle that works fine under Ubuntu on the rPi isn’t recognized by either ArchLinux or Ubuntu on the BeagleBone Black.