beaglebone and tp-link wn722n problems

Hi Gioria,

Have you tried using a powered USB hub between the usb-wifi dongle and the beaglebone? The Wifi dongle can draw a lot of power (especially when operating according the Chinese regulatory domain), and may be overloading the local 5V usb rail on the BB. Get a hub and see if things work out any better.

I am using the exact same wifi dongle and have at least managed to get the drivers to work properly - am just working through getting it to log in to an access point. I used the compat wireless package from here:
(compiled for ath9k_htc using ‘./scripts/driver-select ath9k_htc’)

And firmware from here:

Will post full instructions once I have everything working.

Andrew Glen.

Hi Andrew
Thanks for the replay
Regarding hardware I tried several setups. (with powerd HUB, with several lengths of usb cable) without success. I am working with 3 AMP power supply which should be enough.
We are using the same version of compat-wirless and firmware.

There are links that claim that this is hardware problem, for example

Other that claim that this is configuration problem (wpa and more)!topic/beagleboard/qmcaAcfc8zg
There is one more link that claims that he disables the wpa and it works

currently what I did is to install Ubuntu .
I connected the device and it was recognized immediately.
it is not stable yet but it works.
from time to time it causes my Ethernet connection to hang (released when the dongle is out)
I will continue in this direction