BeagleBone Angstrom setup-scripts /bin/bash^M: bad interpreter error

Hey everyone.

I've got a really stupid error trying to get a cross-compiler
environment on an Arch linux host for a BeagleBone.

$ ./ config beaglebone
bash: ./ /bin/bash^M: bad interpreter: No such file or directory

It seems that the setup-scripts are all using DOS line endings. So I
used the dos2unix tool to change the line endings, but then I started
running into other problems which I couldn't identify, so, I'm
starting from the begining.

Does anyone else have problem with DOS line endings in the current git
repo of the setup-scripts?



Your git client must be adding them. See:

Hi Stan,

As I was writing a reply to your message, I realized what the problem
most likely is. I have global core.autocrlf enabled in my .gitconfig
to fix issues with a previous cross-platform project. I just looked
this setting up again and see that it is probably the culprit. I'll
experiment with it again this evening.

Thanks for the jolt!


Just to follow up, my global .gitconfig was the problem. When I
cloned the repo, the CRLFs were all messed up in my local copy.