BeagleBone Black formatted by mistake

While formatting another USB drive, the BeagleBone Black which was connected in the other USB port got formatted…Now its not booting from external memory card as well…I followed the steps as mentioned in this blog…
still the board doesn’t boot…Any solutions??

If you hold the boot button and have a good uSD card image the board
should boot. If you use one of the eMMC flasher images it will
reprogram your on-board flash and get your board back to normal.

Are any of the blue LEDs flashing when you apply power? Do you have a
serial debug cable you can connect?

I already tried that.Only power led is lit.No other flashing LEDs.
I dont have serial debug cable. I use usb cable for powering the B^3.
Also I could not boot from the external flash drive.
Is the angstrom os bootable img on external flash drive compatible for booting on laptop?? I tried on my laptop and could not boot from the image.

no. get a real 5V power adapter.


The Angstrom image will not boot your laptop unless it's a BeagleBone.

Make sure your uSD card is properly copied. Check the md5 checksum of
your download file, and try looking at the uSD contents on a regular PC.
You should see a small FAT partition at the start of the uSD card that
has at least the files MLO, u-boot.img, and uEnv.txt. If you do not see
these files, your uSD card did not get generated properly.

Assuming your uSD card looks OK, insert it into your BeagleBone and
power up. Then hold the boot button down while you press and release
the reset button. If that doesn't get you booting, you may need a
serial cable to see what's going on or you can send the board back to
get re-imaged. If you didn't actually fry the board, you should be able
to recover with a properly formatted uSD card and the boot button.