Beaglebone Black freezes when using dhclient

I was recently attempting to connect my beaglebone to the network/internet by sharing my mac’s internet connection over usb. I following the steps (seen in another beagleboard groups.google post):

  1. Install Mac drivers from - http://beagleboard.org/Getting%20Started
  2. Connect BBB to Mac through USB
  3. On Mac, System Preferences > Sharing > Internet Sharing > Beaglebone Black
  4. System Preferences > Network, make sure BBB is in the left hand side and shows “Connected”
  5. After SSH’ing into the BBB, run “dhclient”,and then try “ping google.com”.

And I was actually successful at first. I restarted the beaglebone to see if the condition would persist without running dhclient. It didn’t. Then I saw that some other tutorials alternatively suggest that I enter the following command on the beaglebone:

/sbin/route add default gw 192.168.7.1

Thinking that I might learn something, or be able to undo this if something goes wrong I went ahead and tried it. Nothing really happened, and a ping to google.com didn’t work. so I went and tried running “dhclient” again, but now my beaglebone freezes up, and becomes totally unresponsive till I reset it of disconnect/reconnect it!

Nothing I have tried seems to fix this, and I can’t find any info to understand what might be causing this problem. Any ideas what I might have to do to fix this?