Beaglebone Black freezing, USB related?

Hi all

New here, but I’ve been experimenting with the BeagleBone black for a few months now with much success - I2C, SPI, ADC, GPIO, UARTS are all working for me, and I have a my custom cape wining it’s way from the fab to me as I type. But now I’m trying to integrate it with the USB peripherals I’ll need and I am getting constant freezes.

My setup. I have a good power supply (3A 5V) connected via the barrel connector. I have a powered USB hub from a reputable manufacturer and which also has a 3A supply. In that hub I have a bluetooth dongle, an Atheros 9K based Wifi dongle, and a Huawei E3131 3G modem. There’s also an ethernet connection. I’m running a system derived from the Ubuntu self-installer on (ie that plus updates and a few additional packages) with the 3.8.13-bone28 kernel.

The symptoms are after a variable number of hours the device hangs. The heartbeat LED stops and it drops off the network. I’m normally running with HDMI disabled but when I enable it I see nothing on the screen except the console login - no panic message, although when it’s hung the cursor stops blinking. I have to power cycle it and when it comes back there is nothing in the logs.

So I haven’t got much to work from here. I had loads of issues with another Wifi card so switched to one with the atheros chipset, but I still suspect it’s the USB subsystem causing the problems as I had no issues until I started plugging in devices (plus the hotplug doesn’t seem to work reliably under 3.8.13).

So I guess my questions are:

  1. Does anyone have any suggestions - I gather a few people have been here before me.

  2. Is there any way I can get some logs out of this? I’ve been running LInux for 20 years but am new to embedded, and I find a crash with no panic message quite disconcerting!

  3. Is it likely to be hardware or software causing this? The beaglebone black is about 3 months old, so I think it’s the latest revision.

  4. At this point I guess my next option is upgrading to the EXPERIMENTAL or TESTING kernels from Robert Nelson (at 3.12.0-rc3 and rc7 respectively at the moment) - has anyone tried these, and are they fit for purpose?

Thanks in advance.

Cheers… Mike

Suspect your wifi adapter. I run a BBB and BB-xM 24x7 for weeks at a time with no issues and Alfa awus036h wireless. My devices are running The Deck, my custom pentesting Linux based on Nelson’s Ubuntu 13.04.

We have seen similar issues with USB devices on the BBB and are pretty mystified. We suspect a low-level bug in the USB drivers.
Did you ever get a good resolution?

BTW, on the HDMI console you will probably not see kernel panic messages- they are usually brought out only on the serial header, for which you will need a 3.3V USB/serial FTDI adapter.
We also see lots of warnings and USB connect/disconnects in the system logs.

Have you seen any issues with a specific type of USB device? I have had good luck with the Alfa wireless adapters, but have seen issues with some other adapters. YMMV.

We have a system with many USB peripherals, and we have done a lot of experimenting with them.
Some peripherals play nicer than others, and some cause problems right away. In general, the more USB traffic there is, the more likely we are to have problems, and the sooner we see system crashes etc.

Our Huawei Cell modem seems to cause problems, as do some wifi adapters, and some Phidget interface devices, especially with lots of data flowing.
By itself our Logitech quickcam pro 9000 seems OK, but when we are using it along with other devices we see problems.
Simple keyboards/mice, bluetooth adapters, and GPS serial ports seem OK.
Sometimes by minimizing the number of devices attached it mitigates but does not solve the USB connects/disconnects and system crashes.

I should also add that all of these USB devices work rock solid running the same code and drivers on an intel laptop with Ubuntu.

I switched up to Kernel 3.12 and that certainly fixed my stability issues with USB - haven’t seen any USB related issues since then, wireless is fine, 3G modem is fine, everything working. Unfortunately I’ve lost my UARTs, but that’s a different story and no doubt one that will resolve itself as more time is spent on getting 3.12 to stable.

Certainly for anyone else having similar USB issues, there’s a good chance kernel 3.8 is the cause and kernel 3.12 is the solution

Thanks for the update, Mike.

We are experimenting with some 3.12 kernels and it certainly seems to change/improve the problems we are seeing. Not sure if it is 100% yet but it has definitely made a difference.

I had freeze up problems too. I went and bought a cheap wireless keyboard and mouse with a unified receiver, Raygo from $15. Hooked that up and my freeze ups went away.
So I would say it has something to do with USB and perhaps wanting a keyboard/mouse?

Hi all,

I think I may have a potential fix.

I’ve had the same issues with my logitech c920 and my usb wifi adapter.
I have a java program that takes a webcam image using opencv and then it is uploaded to my server.

When I skip either the capture or upload part of my program it is completely stable.
However combined it freezes after about 15-30min.

When I look at the beaglebone black the leds are no longer flashing.
Anyway, this has taken me two weeks to have a potential solution.

looking at the dmesg output i get:

[ 943.043325] omap_i2c 44e0b000.i2c: controller timed out
[ 944.053233] omap_i2c 44e0b000.i2c: controller timed out
[ 945.063042] omap_i2c 44e0b000.i2c: controller timed out
[ 945.069066] tps65217 0-0024: Read from reg 0xf failed
[ 946.074832] omap_i2c 44e0b000.i2c: controller timed out
[ 946.080862] tps65217 0-0024: Read from reg 0x11 failed
[ 946.086629] cpufreq_cpu0: failed to scale voltage down: -110

It seems that the cpu voltage is being or attempted to be scaled down.

I then tried to change the my cpufreq governor to performance and that seemed to have fixed it.

root@beaglebone:~# cpufreq-set -g performance

btw. I am using angstom with kernel 3.8.13

my BBB has now been running without freezing for 14 hours which is 13.5 hours more than before.

hopefully this fixes your guy’s freezing problems as well.

There is a fix for USB available, and I started a crowd-funding project for this:

In addition to Mike Bremford I also had USB issues but after upgrading to kernel 3.12 this issues seem to have been resolved . I would recommend trying 3.12 (default with RobertCNelson’s Ubuntu) to see if it fixes your problem.

In addition to Mike Bremford I also had USB issues but after upgrading to kernel 3.12 this issues seem to have been resolved . I would recommend trying 3.12 (default with RobertCNelson’s Ubuntu) to see if it fixes your problem.

Yes that makes a lot of sense and what I have recommended before.
I have not tried 3.12 myself, and I have seen postings saying that with 3.12 it seems OK.
But recently I also saw postings that say that this did not help them.

I did go through the code, and while there are changes to the driver, it does not seem to
address the issue I found in 3.8.13.

Ideally, Texas Instrument will get the message and pay up…

This fixed my problem on Ubuntu. My steps are as follows.

  1. sudo apt-get install cpufrequtils
  2. sudo cpufreq-set -g performance

在 2013年11月27日星期三 UTC+8上午2:52:02,Dino Tinitigan写道: